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NOTICE
This document contains information about one or more ABB products and may include a description of or a
reference to one or more standards that may be generally relevant to the ABB products. The presence of any
such description of a standard or reference to a standard is not a representation that all of the ABB products
referenced in this document support all of the features of the described or referenced standard. In order to 
determine the specific features supported by a particular ABB product, the reader should consult the product
specifications for the particular ABB product. 

ABB may have one or more patents or pending patent applications protecting the intellectual property in the
ABB products described in this document. 

The information in this document is subject to change without notice and should not be construed as a 
commitment by ABB. ABB assumes no responsibility for any errors that may appear in this document. 

In no event shall ABB be liable for direct, indirect, special, incidental or consequential damages of any nature
or kind arising from the use of this document, nor shall ABB be liable for incidental or consequential damages
arising from use of any software or hardware described in this document. 

This document and parts thereof must not be reproduced or copied without written permission from ABB, and
the contents thereof must not be imparted to a third party nor used for any unauthorized purpose. 

The software or hardware described in this document is furnished under a license and may be used, copied,
or disclosed only in accordance with the terms of such license. This product meets the requirements specified
in EMC Directive 2004/108/EC and in Low Voltage Directive 2006/95/EC.
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INTRODUCTION Functionality Changes
1. INTRODUCTION
This document describes the release of the S+ Engineering: Harmony Gateway Software version 6.0. It is recommended to 
read this instruction in its entirety before installing the BRC-410, HPG-800 or HPC800 module or Harmony Gateway 
software (HGS). HGS 6.0 encompasses the software components and fixes up to and including 5.1 SP2. 

1.1 Functionality Changes
Harmony Gateway software version 6.0 adds the following functionality:

• Support for up to eight (8) Modbus TCP Servers and one hundred twenty eight (128) Clients (applicable for the 
HPC800 module only). 

• Support for the Harmony Process Controller (HPC800) Module.

• Support for 10,000 points (applicable to the HPC800 module only).

• On/Off Client connection scan for pre-configuring at the unit level within a Client connection and adding units during 
commissioning. This functionality permits a function block to turn off a client connection from sending a Modbus 
command to a unit.

• Triggered Write (FNC 5, 6, 15, 16) allows the function block to control precisely when the write command is sent.

• Optionally each command (all FNC's) can have a separate enable block if the Trigger option is not used.

• A Client Connection Status Page tab has been added to the Monitor Link Status Window to monitor the status of the 
128 available clients.

• Client Heartbeat Timeouts: The Heartbeat Parameter Table enables an individual unit timeout and a quality 
override block for each Heartbeat to be configured. There can be 256 individual Heartbeat Timeouts. Individually 
configured Override Blocks replace the global override feature previously defined at block 31022.

NOTE: Configurations that previously used block 31022 must reconfigure the Heartbeat using the Heartbeat 
Parameter Table.

• The status of each Modbus command can be monitored if required. If the redundancy option is selected, then the 
status output contains the Modbus Reply status for both the primary and secondary TCP ports. A Composer macro 
"HGS_CMD_STATUS" can be used to separate the status for each port. 

The status output for the ports is as described in Table 1. 

Table 1: Command Status Values

Modbus Replies Reply Status Value 

NO_ERROR 0

ILLEGAL_FUNCTION 1

ILLEGAL_DATA_ADDRESS 2

ILLEGAL_DATA_VALUE 3

SLAVE_DEVICE_FAILURE 4

ACKNOWLEDGE 5

SLAVE_DEVICE_BUSY 6

NEGATIVE_ACKNOWLEDGE 7

MEMORY_PARITY_ERROR 8

TIMEOUT 16

CORRUPTDATA 32

SENT 64

INITIALIZING 128

DISABLED 255
2VAA002585-600 1



Fixed Issues INTRODUCTION
• Disconnect /Connect toggle to start and stop communication with the Logical ICI has been added to the Tools 
menu.

• Improved Verify Loaded Configuration. Differences are logged to a text file for the user to view.

• HGS 6.0 uses MS Access 2007, all previous HGS configurations must be converted when upgrading using the 
HGS MDB Convert Utility.

• Removal of redundancy option in Module Licensing view. All software can run within redundant modules. This 
includes single interface licenses upgraded to version 6.0 from previous versions of software. One license per 
module/redundant pair is required. 

1.2 Fixed Issues
The following issues are corrected with the release of Harmony Gateway software version 6.0.

Table 2: Fixed Issues

Issue Correction of Issue

Modbus TCP Client Connection Configuration screens 
do not resize.

HGS-UI-001

Each of the three sections of the Modbus TCP Client 
Connection Configuration screen can be dragged to a 
size chosen by the user.

Wrong Status Index is created for default Client 
Connection records. 

The first default client is called Client1 with a Status 
Index of 0 but Client2 is assigned a Status Index 2 
instead of 1.

HGS-OP-011

The index number is now correct which is one (1) less 
than the default client number.

The Tools > Initialize or Reinstall or Verify or 
Monitor > Module Address dialog box cannot be 
moved.

HGS-UI-002

The dialog boxes can be moved within the HGS menu 
system.

The Tools > Initialize or Reinstall or Verify or 
Monitor > Module Address dialog box Control 
Network, Control Unit, and Controller Fields should be 
dimmed as they are no longer modified here. 

HGS-OP-012

The Module address can now only be 
configured/modified in the Configuration > HGS 
Module Address dialog box.

The documentation has been modified to reflect this 
change.

Records copied from Excel and back into the mapping 
add an extra record. Excel adds an extra CRLF which 
is treated as another record when pasting.

HGS-OP-013

A record is no longer appended to the mapping records 
when copying records from Excel back into the 
mapping.

The Error Log messages have the word initialized 
misspelled.

HGS-OP-014

The word initialized is now spelled correctly. 

In the Modbus TCP Client screen, right-clicking on a 
record for the cut/copy/append dialog box it is 
displayed at the top of the screen display. 

HGS-UI-003

The cut/copy/append dialog box is now displayed 
beside the record chosen. 

The module HPG800/BRC410 can red light with 
LED's 3,5,6, if HGS is started with the Ethernet cable 
disconnected. 

It can also occur if there is an extra Invoke C added to 
the function block configuration.

HGS-OP-015

A divide by zero error has been corrected. 
2 2VAA002585-600



INTRODUCTION Manual
1.3 Manual
The manual has been reconfigured to provide a cohesive view of the software and its configuration.

1.4 Compatibility

1.4.1 HGS Compatibility

Harmony Gateway Software version 6.0 can co-exist on the same server machine based on computer capacity with the 
following versions:

• HGS 5.1

• HGS 5.1 SP1

• HGS 5.1 SP2

• GPI 4.0 

• GPI 4.0 RU1

All software manuals must be referenced for computer requirements.

1.4.2 Firmware Compatibility

The firmware compatibility for Harmony Gateway Software are as follows:

• The Harmony Gateway module (HPG-800) requires firmware revision L_9 or later. 

• BRC-410 (firmware M_0). 

NOTE: For the HPG-800 and BRC-410 rev M_0, only use the Test and Accept when doing online configuration. 
Users should be aware of possible Bad Quality of values when performing a Go Back or Additional during online 
configuration.

When there is an Invoke C error, the message is 
incorrect.

HGS-OP-016

The correct error message is now logged.

Add and Modify module license features function 
differently.

When modifying the loop/pcu/module of an existing 
module license by clicking Accept, it prompts whether 
the loop/pcu/module is correct. If the answer is yes it 
then goes to the “Testing" dialog box, but if the answer 
is no it states that the module address is not saved 
and then closes all dialog boxes.

HGS-OP-017

Both Add and Modify module license features function 
the same.

Edit and View license menu functions provide the 
same features and functions.

The View of the license strings is redundant as the 
same information is available from the Edit submenu 
under licenses.

HGS-UI-004

The View submenu under Licenses has been removed. 

The Edit submenu provides the functions 
Add/Modify/Delete, all licenses and features can be 
viewed.

Harmony Gateway Software will not reconnect to a 
Client after TCP failure due to a command reply 
timeout. This will only happen if all commands on a 
TCP Client Configuration in HGS are of a write type 
FNC's 5, 6, 15, or 16. 

HGS-OP-018

This has been corrected and the HGS software will not 
disconnect if the TCP Client Configuration types are all 
writes types.

Table 2: Fixed Issues (Continued)

Issue Correction of Issue
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Engineering Tools Compatibility INSTALLATION
• The BRC-410 (firmware M_1) is required in order to use the Online Configuration Go Back or Additional features. 
Refer to the module hardware instructions for additional hardware and firmware requirements.

• HPC800 (firmware A_2).

1.4.3 Engineering Tools Compatibility

The Harmony Gateway Software is compatible with Composer versions 5.1 SP2 and 6.0 or later. 

Composer 5.1 SP2 is required when running Windows Server 2008 or Windows 7 (32-bit), using either the HPG-800, or 
BRC-410 module and the Harmony Gateway software. 

Composer 6.0 or later is required when running Windows Server 2008 or Windows 7 (32-bit or 64-bit), using the HPG-800, 
BRC-410, or the HPC800 module and the Harmony Gateway software.

2. INSTALLATION
Harmony Gateway Software version 6.0 is available as a download from ABB SolutionsBank (Control Products & Systems 
\Symphony Plus\Engineering\Symphony Plus - Composer Harmony).

Follow the given steps to download the software:

1. Download the SetupHGS60.msi from ABB SolutionsBank.

2. Copy the file to the local machine where HGS 6.0 is to be installed.

3. Run the SetupHGS60.msi.

NOTE: Previous Composer project files must be converted with Composer 6.0 and previous HGS project files must be 
converted using the HGS 6.0 MDB Convert Utility.

Licenses are available from the ABB Software License Administration System.

3. RELATED DOCUMENTS
ABB documentation can be found in the ABB Library or SolutionsBank (http://solutionsbank.abb.com). The following table 
lists additional documents that relate to Harmony Gateway Software.

4. SUPPORT
Contact ABB technical support for assistance in problem reporting.

5. REVISION HISTORY

Table 3: Harmony Gateway Related Documents

Document Number Document Title

2VAA002581-600 S+ Engineering: Harmony Gateway Software Version 6.0 User Manual

3BUA001154R0001 Rev B Harmony Gateway Module (HPG-800) User Manual

2VAA000720R0001 S+ Control: P-HC-BRC-41000000 Bridge Controller with Ethernet User Instruction

2VAA001586 S+ Control: HPC800 Harmony Process Controller User Manual

Rev. Description Date / Initial

Initial S+ Engineering: Harmony Gateway Software version 6.0 Release Notes 01/2013 / LT
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The information in this document is subject to change 
without notice and should not be construed as a 
commitment by ABB. ABB assumes no responsibility 
for any errors that may appear in this document.
In no event shall ABB be liable for direct, indirect, 
special, incidental or consequential damages of any 
nature or kind arising from the use of this document, nor 
shall ABB be liable for incidental or consequential 
damages arising from use of any software or hardware 
described in this document.
This document and parts thereof must not be 
reproduced or copied without written permission from 
ABB, and the contents thereof must not be imparted to 
a third party nor used for any unauthorized purpose.
The software or hardware described in this document is 
furnished under a license and may be used, copied, or 
disclosed only in accordance with the terms of such 
license.
This product meets the requirements specified in EMC 
Directive 2004/108/EC and in Low Voltage Directive 
2006/95/EC.
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