
Experion PKS

Qualification and Version Control
User
Guide
EP-DCX253

R210
10/04



ii Experion PKS Qualification and Version Control User Guide R210
Honeywell 10/04

Notices and Trademarks

Copyright 2004 by Honeywell International Inc.
Release R210  October 25, 2004

While this information is presented in good faith and believed to be accurate, Honeywell disclaims
the implied warranties of merchantability and fitness for a particular purpose and makes no
express warranties except as may be stated in its written agreement with and for its customers.

In no event is Honeywell liable to anyone for any indirect, special or consequential damages. The
information and specifications in this document are subject to change without notice.

Honeywell, TotalPlant, and Experion PKS are registered trademarks of Honeywell International
Inc.

Other brand or product names are trademarks of their respective owners.

Honeywell

Industry Solutions

2500 West Union Hills

Phoenix, AZ  85027

1-800 343-0228



R210 Experion PKS Qualification and Version Control User Guide iii
10/04 Honeywell

About This Document

Revision Notes
The following list provides notes concerning all revisions of this document.

Doc ID Rel ID Date Notes

EP-DCX253 R210 10/25/04 Initial Release

References
The following list identifies all documents that may be sources of reference for material
discussed in this publication.

Document Title Doc ID



About This Document

iv Experion PKS Qualification and Version Control User Guide R210
Honeywell 10/04

Contacts

World Wide Web

The following lists Honeywell’s World Wide Web sites that will be of interest to our
industrial automation and control customers.

Honeywell Organization WWW Address (URL)

Corporate http://www.honeywell.com

Automation & Control Solutions http://www.acs.honeywell.com

International http://www.honeywell.com/Business/global.asp
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Contact us by telephone at the numbers listed below.

Organization Phone Number

United States
and Canada

Honeywell International Inc.
Automation & Control Solutions

1-800-223-8947 Sales
416-502-5200 Canada
1-800-822-7673 Tech. 

Support

Asia Pacific Honeywell Ltd.
Hong Kong

852-2331-9133

Europe Honeywell Ltd.
Brussels, Belgium

32 2-728-2704

Latin America Honeywell International Inc.
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Symbol Definitions
The following table lists those symbols used in this document to denote certain
conditions.

Symbol Definition

ATTENTION: Identifies information that requires special
consideration.

TIP: Identifies advice or hints for the user, often in terms of
performing a task.

REFERENCE -EXTERNAL: Identifies an additional source of
information outside of the bookset.

REFERENCE - INTERNAL: Identifies an additional source of
information within the bookset.

Indicates a situation which, if not avoided, may result in equipment
or work (data) on the system being damaged or lost, or may result in
the inability to properly operate the process.

CAUTION: Indicates a potentially hazardous situation which, if not
avoided, may result in minor or moderate injury. It may also be used
to alert against unsafe practices.

CAUTION symbol on the equipment refers the user to the product
manual for additional information. The symbol appears next to
required information in the manual.

WARNING: Indicates a potentially hazardous situation which, if not
avoided, could result in serious injury or death.

WARNING symbol on the equipment refers the user to the product
manual for additional information. The symbol appears next to
required information in the manual.

WARNING, Risk of electrical shock: Potential shock hazard where
HAZARDOUS LIVE voltages greater than 30 Vrms, 42.4 Vpeak, or
60 VDC may be accessible.
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Symbol Definition

ESD HAZARD: Danger of an electro-static discharge to which
equipment may be sensitive. Observe precautions for handling
electrostatic sensitive devices

Protective Earth (PE) terminal:. Provided for connection of the
protective earth (green or green/yellow) supply system conductor.

Functional earth terminal: Used for non-safety purposes such as
noise immunity improvement. NOTE: This connection shall be
bonded to Protective Earth at the source of supply in accordance
with national local electrical code requirements.

Earth Ground. Functional earth connection. NOTE: This
connection shall be bonded to Protective Earth at the source of
supply in accordance with national and local electrical code
requirements.

Chassis Ground: Identifies a connection to the chassis or frame of
the equipment shall be bonded to Protective Earth at the source of
supply in accordance with national and local electrical code
requirements.



R210 Experion PKS Qualification and Version Control User Guide vii
10/04 Honeywell

Contents

Qualification and Version Control System ...............................................1
In This Document ......................................................................................................... 1

Qualification and Version Control System Overview ................................................... 3
QVCS Manager Menus ..........................................................................................................6
QVCS Manager Toolbar.........................................................................................................9

Using QVCS Manager ............................................................................................... 10
Launching QVCS Manager from Control Builder..................................................................10

Manager Window...................................................................................11
Main View................................................................................................................... 11

Object List ............................................................................................................................13
Positioning to the Nearest Object Name ..............................................................................13
Right-click Context Menu .....................................................................................................13

Query View................................................................................................................. 14
Query List.............................................................................................................................15
Forming and Executing the Query........................................................................................15
Context Menu.......................................................................................................................16

Versions Window ...................................................................................17
Using the Versions Window ....................................................................................... 18

Opening the versions window ..............................................................................................18
Comparing versions .............................................................................................................18
Viewing object version in text format....................................................................................19
Changing view size ..............................................................................................................19
Printing version information..................................................................................................19

History Window......................................................................................21
Using the History Window.......................................................................................... 23

Opening the history window .................................................................................................23
Printing the history ...............................................................................................................23
Filtering the history logs .......................................................................................................23

Log Window...........................................................................................25



Contents

viii Experion PKS Qualification and Version Control User Guide R210
Honeywell 10/04

Logs List .............................................................................................................................. 27

Using the Log Window................................................................................................28
Opening the log history window........................................................................................... 28
Printing the log history......................................................................................................... 28
Filtering the history logs ...................................................................................................... 28

Check-in Dialog Box.............................................................................. 29
Using the Check-in Dialog Box...................................................................................31

Invoking the check-in dialog box ......................................................................................... 31
Object to be checked-in....................................................................................................... 31
Entering comments ............................................................................................................. 31
Entering revision type.......................................................................................................... 31
Revert Label ........................................................................................................................ 32

Check-out Dialog Box ........................................................................... 33
Using the Check-out Dialog Box ................................................................................35

Invoking the check-out dialog box ....................................................................................... 35
Entering comments ............................................................................................................. 35

Properties Dialog Box ........................................................................... 37
Using the Properties Dialog Box ................................................................................38

Invoking the properties dialog box....................................................................................... 38
Version properties ............................................................................................................... 38
Change qualification state ................................................................................................... 38
Revert labels ....................................................................................................................... 38

Properties in Control Builder.......................................................................................39

Qualification State Configuration Dialog Box ........................................ 41
Qualification Life Cycle States Grid ..................................................................................... 42

Using the Qualification State Configuration Dialog Box .............................................43
Adding qualification state .................................................................................................... 43
Modifying Qualification State............................................................................................... 44
Deleting Qualification State ................................................................................................. 45
Qualification life cycle transitions grid.................................................................................. 45
Configuring state transition requirements............................................................................ 46

Change Qualification State Dialog Box ................................................. 51
Using the Change Qualification State Dialog Box......................................................53

Invoking change Qualification State .................................................................................... 53



Contents

R210 Experion PKS Qualification and Version Control User Guide ix
10/04 Honeywell

Changing the qualification state ...........................................................................................53

Configure Electronic Signature Dialog Box............................................55
Using the Electronic Signature Dialog Box ................................................................ 57

Invoking the configure electronic signature dialog box.........................................................57

Revert Level Maintenance Dialog Box...................................................59
Using the Revert Level Maintenance Dialog Box ...................................................... 60

Invoking the revert level maintenance dialog box.................................................................60
Existing revert labels list.......................................................................................................60
Adding a new revert label.....................................................................................................60
Deleting a revert label ..........................................................................................................61
Modifying a revert label ........................................................................................................61

Apply/Remove Labels to Version Dialog Box.........................................63
Using Apply/Remove Labels to Version Dialog Box .................................................. 64

Invoking the apply/remove revert labels to version dialog box .............................................64
Adding a revert label to the existing version.........................................................................64
Removing a revert label from the existing version................................................................64
Applying/removing labels on the object version ...................................................................65
Label maintenance...............................................................................................................65
Viewing references...............................................................................................................66

Apply/Remove Revert Labels to Contained Dialog Box.........................67
Using Apply/Remove Revert Labels to Contained Dialog Box .................................. 68

Invoking the apply/remove revert labels to contained dialog box .........................................68
Applying/removing the revert labels to contained objects ....................................................68
Adding a revert label to existing objects...............................................................................68
Removing a revert label from existing objects......................................................................69
Applying/removing labels of contained objects.....................................................................69
Label maintenance...............................................................................................................69

Apply/Remove Labels to All Dialog Box.................................................71
Using Apply/Remove Revert Labels to All Dialog Box............................................... 72

Invoking the apply/remove revert labels to all dialog box .....................................................72
Applying/removing revert labels to all...................................................................................72
Adding a revert label to all....................................................................................................72
Removing a revert label to all...............................................................................................73
Applying/removing labels to all in Control Builder project and library trees ..........................73
Label maintenance...............................................................................................................73



Contents

x Experion PKS Qualification and Version Control User Guide R210
Honeywell 10/04

Revert to a Version Dialog Box ............................................................. 75
Using the Revert to a Version Dialog Box ..................................................................75

Invoking the revert to a version dialog box .......................................................................... 75
Reverting to a version ......................................................................................................... 76

Revert to Label Dialog Box ................................................................... 77
Using the Revert to Label Dialog Box ........................................................................78

Invoking the revert to label dialog box ................................................................................. 78
Reverting to a label ............................................................................................................. 78

Relaxed Loading Support for QVCS ..................................................... 79
Relaxed Load Function...............................................................................................79

About relaxed load function................................................................................................. 79
Typical relaxed load functional scenario.............................................................................. 79
Initiating queries for non-QVCS objects .............................................................................. 80
Making multiple object qualification state transitions ........................................................... 82

Version Difference Tool (Diff Tool) ........................................................ 85
Diff Tool Toolbar.................................................................................................................. 88

Using the Diff Tool ......................................................................................................89
Invoking the Diff Tool........................................................................................................... 89
Reading the differences ...................................................................................................... 89
Scrolling the difference windows ......................................................................................... 89
Resizing an individual version window ................................................................................ 89
Printing the difference output............................................................................................... 90

QVCS Troubleshooting ......................................................................... 91
Error Handling Overview ............................................................................................91

QVCS Error Messages ...............................................................................................92
QVCS configuration tips ...................................................................................................... 92



Tables

R210 Experion PKS Qualification and Version Control User Guide xi
10/04 Honeywell

Tables
Table 1  Toolbar Icons and Their Functions.................................................................... 9
Table 2  Diff Tool Toolbar .............................................................................................. 88

Figures
Figure 1  QVCS Main Window......................................................................................... 5
Figure 2  Manager Window - Main View........................................................................ 12
Figure 3  Manager Window - Query View...................................................................... 14
Figure 4  Versions Window............................................................................................ 17
Figure 5  History Window .............................................................................................. 22
Figure 6  Log Window.................................................................................................... 26
Figure 7  Check-in Dialog Box....................................................................................... 30
Figure 8  Check-out dialog box...................................................................................... 34
Figure 9  Properties Dialog Box..................................................................................... 37
Figure 10  Properties dialog as part of Control Builder Configuration Forms for Tagged

Objects ................................................................................................................... 39
Figure 11  Qualification Life Cycle Configuration .......................................................... 42
Figure 12  Change Qualification State dialog box ......................................................... 51
Figure 13  Change Qualification State dialog box with List expanded .......................... 52
Figure 14  Electronic Signature dialog box.................................................................... 55
Figure 15  Configure Electronic Signature dialog box ................................................... 56
Figure 16  Revert Label Maintenance dialog box.......................................................... 59
Figure 17  Apply/Remove Revert Labels to Version ..................................................... 63
Figure 18  Remove Revert Label Confirmation Dialog.................................................. 65
Figure 19  Apply/Remove Revert Label Dialog showing Objects Referencing the selected

object version. ........................................................................................................ 66
Figure 20  Apply/Remove Labels to Contained dialog box ........................................... 67
Figure 21  Apply/Remove Revert Labels to All.............................................................. 71
Figure 22  Revert to a Version Dialog Box .................................................................... 75
Figure 23  Revert to Label Dialog Box........................................................................... 77
Figure 24  Diff Tool User Interface ................................................................................ 86
Figure 25  Diff Tool – Difference Between Two Versions.............................................. 87
Figure 26  Error Message Box....................................................................................... 91



Figures

xii Experion PKS Qualification and Version Control User Guide R210
Honeywell 10/04



R210 Experion PKS Qualification and Version Control User Guide 1
10/04 Honeywell

Qualification and Version Control System

In This Document
• Qualification and Version Control System Overview

− QVCS Manager Menus

− QVCS Manager Toolbar

• Using QVCS Manager

− Launching QVCS Manager from Control Builder

• QVCS Windows:

− Manager Window

− Versions Window

− History Window

− Log Window

• QVCS Dialog Boxes

− Check-in Dialog Box

− Check-out Dialog Box

− Properties Dialog Box

− Qualification State Configuration Dialog Box

− Change Qualification State Dialog Box

− Configure Electronic Signature Dialog Box

− Revert Level Maintenance Dialog Box

− Apply/Remove Labels to Version Dialog Box

− Apply/Remove Revert Labels to Contained Dialog Box

− Apply/Remove Labels to All Dialog Box

− Revert to a Version Dialog Box



Qualification and Version Control System
In This Document

2 Experion PKS Qualification and Version Control User Guide R210
Honeywell 10/04

− Revert to Label Dialog Box

− Relaxed Loading Support for QVCS

• Version Difference Tool (Diff Tool)

• QVCS Troubleshooting



Qualification and Version Control System
Qualification and Version Control System Overview

R210 Experion PKS Qualification and Version Control User Guide 3
10/04 Honeywell

Qualification and Version Control System Overview
The Qualification and Version Control System (QVCS) provides version management
for all tagged objects and a customer defined lifecycle management.

Lifecycle management is used:

• to define the qualification states objects will go through from inception to
decommissioning,

• for the approvals required to move from one qualification state to another, and

• to control what qualification state a strategy must be in to be downloaded into a
control execution environment such as the C200 controller.

In addition, the QVCS maintains a version repository of each object and provides an
audit trail and compare capability for all configuration changes.

When the QVCS option is enabled by the license, the system will restrict certain
engineering actions like modifications and controller loads.  An object needs to be
checked into the QVCS system and assigned to an appropriate qualification state to allow
load to a controller.  Before modifications can be made an object needs to be checked out
once it is under version control.

The QVCS Manager, launched from Control Builder, enables checking out objects,
checking in objects, viewing version properties, performing Administrative tasks like
viewing Version System Logs, configuring Electronic signatures. Revert Label specific
operations can be performed, like Label Maintenance, Applying/Removing Revert Labels
to Objects and Reverting to Version/Label.

QVCS Manager, the main interface of the Qualification and Version Control System, is
tightly coupled to the instance of the Control Builder, which launched it.   Typical use
includes launching QVCS Manager after selecting one or more Strategies/User
Templates in Control Builder. All the selected objects are then displayed in the QVCS
Manager where Version Control specific operations may be performed. All version
control operations are performed in QVCS Manager only.

QVCS concepts:

• Qualification life cycle – capability to enforce GAMP guidelines regarding control
system development.

• Objects definition – all tagged objects in the Experion PKS Control Builder such as
CM, SCM, CPM, CEE, IOLIM, FIM, IO, etc.
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• Version repository – the QVCS maintains a repository with all versions of each
configured object.

− Check-out – means locking a particular version of an object in the QVCS and
allowing it to be changed by a single user.

− Check-in – to place a new or modified object under version control.

− Audit trail – a log of all QVCS interactions for audit purposes.

− Revert – the retrieval of a specific version of an object or set of objects.

− Revert Label – a means to identify a set of unique objects that should always be
used together to perform a certain control function.

− QVCS administration – all tasks that are required to initially setup and maintain the
Qualification and Version Control system.

− Fallback state – defines the qualification state the object will revert to after it has
been modified and checked back into the QVCS.

− Restricted signing state – this option allows the implementation of the four-eye
GAMP principle (Good Automation Manufacturing Principles).  The user who
made the qualification transition to the state indicated by the restricted signing state
cannot make the qualification state transition to the qualification state on which this
restricted signing state is defined.

The following windows are available through QVCS Manager:

• Manager Window – Main View

• Manager Window – Query View

• Versions Window

• History Window

• Qualification and Version Control System Log Window
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Figure 1  QVCS Main Window
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QVCS Manager Menus

Print Preview

Print

Exit

Copy

Select All

Invert Selection

Toolbar

Object Properties

Version Details

Refresh

Check Out

Check In

Object Versions

Object History

Revert Labels

Compare

Administration

Apply/Remove

Revert

Label Maintenance

To selected version

All objects

All contained object

To a version

To a label

with Previous version

with Another version

Configure Electronic Signature

Configure Qualification States

View VCS Logs

Tile

Cascade

Show Explorer

Window 1

Window 2

Knowledge Builder

About

File Edit View Tools Window Help

with Monitor version

with Checked Out version

Change Qualification State

Menu Name Menu Item Description

File Print Preview Shows the preview of the contents of the
active window that will be printed to the
printer.

Print Prints the current active window
contents. Brings up the Print dialog box
to choose the printer and the contents
are printed.

Exit Closes the QVCS Manager.
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Edit Copy This menu is active only when the
Versions Window is selected, and copies
the contents of the Version Information
text window to the clipboard.

Select All Selects all items in the active window.

Invert Selection Inverts the selected items in the active
window.  All selected items in the list are
unselected, and the rest are selected.

View Toolbar Shows/hides the QVCS toolbar.

Object Properties Shows the Properties Dialog of the
selected object.

Version Details Loads the details of the version to the
Versions Window.

Refresh Refreshes the active window.

Tools Check Out Shows the Check Out dialog for all
selected objects.

Check In Shows the Check In dialog for all
selected objects.

Object Versions Shows the Versions Window for the
selected objects.

Object History Shows the History Window for the
selected objects.

Revert Labels Apply/Remove Labels:

• To selected version:
Applies/removes the labels to the
selected version of the objects only.
Shows the Apply/Remove Labels to
Version dialog

• All objects in project tree:
Applies/removes the labels to the
current version of all objects in the
project and library trees.  Shows the
Apply/Remove Labels to All dialog.

• All contained objects:
Applies/removes the labels to all of
the contained objects.  Shows the
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Apply/Remove Labels to Contained
dialog.

 Revert:

• To a version:  Applies Revert to
Version to selected objects.  Shows
the Revert to Version dialog.

• To a label:  Shows the Revert to
Label dialog.

Label Maintenance:   Shows the Revert
Label Maintenance Dialog.

Compare With Previous Version:  Compares the
selected object version with the previous
object version.

With Another Version:  Compares the
selected object version with another
object version.

With Monitor Version:  Compares the
selected object version with the monitor
object version.

With Checked Out Version:  Compares
the selected object version with the
currently checked out version of the
object in the Project/Library tree in
Control Builder.

Change
Qualification State

Shows the Change Qualification State
dialog for the selected object.

Administration Configure Electronic Signature:  Shows
the Configure Electronic Signature
dialog.

Configure Qualification States:  Shows
the Qualification State Configuration
dialog.

View QVCS Logs:  Shows the
Qualification and Version Control
System Log Window.

Window Tile Tiles all opened windows.
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Cascade Cascades all opened windows.

Show Manager Brings the Manager window to the front
of all other windows.

Window 1…n Lists all open MDI windows

Help Knowledge Builder Launches the Knowledge Builder and
activates the main QVCS page.
Selecting the F1 key will also launch
Knowledge Builder.

About Shows the About dialog.

QVCS Manager Toolbar

The toolbar provides fast and easy access to frequently used functionality. Below is the
list of toolbar items and the functionality associated with it.  Click on the toolbar button
to invoke the function.

Table 1  Toolbar Icons and Their Functions

Toolbar
Icon

Tool Tip Menu Item

Check Out Tools->Check Out

Check In Tools->Check In

Object Properties View->Object Properties

Object History Tools->Object History

Compare Previous Tools->Compare->with Previous version

Revert Tools->Revert Labels->Revert->To label
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Using QVCS Manager

ATTENTION

Prior to using QVCS, the users must be defined on the Operator
Configuration window in Station.

Launching QVCS Manager from Control Builder

Manager can be launched from the Control Builder using the options shown below.

• Launch from the Control Builder Tools Menu:
Tools -> QVCS Manager

• Launch from the Project Tree:
Right-click context menu -> QVCS Manager

If the Qualification and Version Control System is not licensed, the menu item will not
be available.

You can close the QVCS Manager by closing the instance of the QVCS Manager or the
Control Builder.
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Manager Window
The Manager window is the main window of the QVCS Manager and is activated when
the application is launched. This window contains 2 views: Main View and Query View.

Main View
The Manager Main view lists all the objects selected in the Control Builder when the
QVCS Manager is launched from the Control Builder. For example, if the
example_cascade and example_motor strategies were selected in the Control Builder and
QVCS Manager was invoked, the display would be as shown in the Figure below.

The list does not automatically refresh when new objects are selected in the Control
Builder.  To update the list, return to Control Builder, select the new objects to be shown,
and launch the QVCS Manager again. All basic QVCS operations on the object can be
performed from the Main view. The operation can be invoked from the menu, toolbar or
the right-click context  menu.

The main window will show the list of selected objects and their version attributes in the
object list.
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Figure 2  Manager Window - Main View



Manager Window
Main View

R210 Experion PKS Qualification and Version Control User Guide 13
10/04 Honeywell

Object List

• The objects selected in Control Builder will be listed in Alphabetical Order using the
Object name.

• Clicking on the column name will sort the list in the column, and the sort order will
toggle between ascending and descending.

• The object in the list can be selected using the standard item selection procedure of
windows common list control (i.e. Click, Shift + Click, Ctrl+Click)

− Multiple objects can be selected in the list

− Right-mouse click will bring up the Context menu

Positioning to the Nearest Object Name

• Type the name of the object in the Edit box. The list will bring the nearest object to the
top of the list that matches to the typed name.

• This functionality will work only if the objects are sorted on the name of the object
otherwise the feature is disabled.

Right-click Context Menu
The context menu contains options to:

• Check-in

• Check-out

• View object version

• View object history

• Change qualification state

• View object properties

• Perform Revert Label operations

• Compare versions
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Query View
The Manager Query view lists the objects based on a query, no Control Builder object
selection is required. The operation can be invoked from the menu, toolbar or the right-
click menu.  The contents of the window can be printed by selecting File -> Print from
the drop-down menu.

Figure 3  Manager Window - Query View
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Query List

• The objects based on the query will be listed in Alphabetical Order using the Object
name.

• Clicking on the column name will sort the list on the particular column and the sort
order will toggle between ascending and descending.

• The object in the can be selected using the standard item selection procedure of
windows common list control (i.e. Click, Shift + Click, Ctrl+Click).

• Multiple objects can be selected in the list.

• Right-mouse click will bring up the Context menu.

Forming and Executing the Query
• The Options combo box will show four options for the query.

− QVCS State

− Qualification State

− Revert Label

− Reference

• The available values will be filled based on the selection in Options combo.

State Available values

If QVCS State is selected, the pre-
defined QVCS states will be listed. Select VCS State

<None>
Checked In
Checked Out
Deleted from Tree
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State Available values

If Qualification State is selected, the
customer defined qualification states
will be listed.

Select Qualification State

<None>
Implemented
Testing
Released
Withdrawn

If Revert Label is selected, the
customer defined Revert Labels
defined in the QVCS will be listed.

Select Revert Label

<None>
REVERT_LABEL_1
REVERT_LABEL_2

If the Reference is selected, the object
name must be entered manually to
find references.

example_motor

• After selecting the query option and the value for the query, clicking on the List button
will populate the query list based on the query

Context Menu
The context menu will have options to:

• Check-in

• Check-out

• View Object Version

• View Object History

• Change Qualification State

• View Object Properties

• Perform Revert Label operations and Compare versions
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Versions Window
The versions window is used to view all the versions of the object.  For each selected
object a separate Versions window is opened. Two version window instances for the
same object cannot be opened.

In the version detail view, the version information of the object can be viewed in the
version detail view on the right side, and different versions of the object can be
compared.

Figure 4  Versions Window
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Using the Versions Window

Opening the versions window

Select the object in the Main or Query View -> select the Tools drop-down menu ->
select Object Versions.

Comparing versions

Compare version with previous version

Step Action

1 Select a version in the list by clicking on it.

2 Select Compare from the drop-down menu -> select With Previous Version.
This will launch the Diff Tool to compare the versions of the object.

Compare version with another version

Step Action

1 Select a version in the list by clicking on it.

2 Select Compare from the drop-down menu -> With Another Version.

3 The mouse cursor will change.
Select another version to compare by clicking on it.
This will launch the Diff Tool to compare the selected versions.

Compare version with monitor version

Step Action

1 Select a version in the list by clicking on it.

2 Select Compare from the drop-down menu -> With Monitor Version.
This will launch the Diff Tool to compare the selected versions.
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Compare version with checked-out version

Step Action

1 Select a version in the list by clicking on it.

2 Select Compare from the drop-down menu -> With Checked-out Version.
This will launch the Diff Tool to compare the selected versions.

Viewing object version in text format

Step Action

1 Select a version in the list by double-clicking on it, or selecting “View Version
Details” in the context menu.

2 The information of the selected version is loaded into the version details view.

Changing view size
Use the splitter bar to change the size of the view by dragging horizontally.

Printing version information
In the Versions view:  Select the File drop-down menu -> select Print.
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History Window
The History window will display the set of logs associated with the selected object. For
each selected object a separate History window is opened. Two history window instances
for the same object cannot be opened. The history can be filtered based on the query.
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Figure 5  History Window
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Using the History Window

Opening the history window

Select the object in the Main or Query View -> select the Tools drop-down menu ->
select Object History.

Printing the history
In the History view:  Select the File drop-down menu -> select Print.

Filtering the history logs

Step Action

Select the filtering options provided in the window.  For example, to filter logs
with respect to:

Date: Select the relational operator from the combo adjacent to the
date label and select the date from the date time picker.

Action: Select the actions listed in the combo adjacent to the action
label.

User: Select the particular user from the list of users in the combo
adjacent to the user label.

1

Version: Select the relational operator from the combo adjacent to the
version label and enter the version number in the edit box
provided.

2 Click on the List button and the logs will be populated matching the condition
of the query. All the query options will be ANDed to generate the result of the
query.
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Log Window
The QVCS log window displays any logs that have been generated by the QVCS. These
include administrative logs, operational logs and object version specific logs. Only one
instance of this window can be opened. The log entries can be filtered based on different
query options.

Note: Administrative privileges are required to access this window.
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Figure 6  Log Window
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Logs List
• The logs list shows all logs generated by the QVCS.

• The logs are arranged in the reverse chronological order, latest log first.

• The description and the comment of the selected log item is shown in the edit boxes
provided below the list

• Clicking the column name will sort the list on the particular column and the sort order
will toggle between ascending and descending.

• The Description and comment of the selected history log are shown in the Description
and Comment windows respectively.
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Using the Log Window

Opening the log history window
Select the Tools drop-down menu -> select Administration -> View QVCS Logs.

Printing the log history
Select the File drop-down menu -> select Print.

Filtering the history logs

Step Action

Select the filtering options provided in the window.  For example, to filter logs
with respect to:

Date: Select the relational operator from the combo adjacent to the
date label and select the date from the date time picker.

Action: Select the actions listed in the combo adjacent to the action
label.

User: Select the particular user from the list of users in the combo
adjacent to the user label.

1

Source: Enter the source (object name/workstation name) in the edit box
provided adjacent to the source label.

2 Click on the List button and the logs will be populated matching the condition
of the query. All the query options will be ANDed to generate the result of the
query.
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Check-in Dialog Box
Checking-in an object is to take the current image of an object as it exists in the ERDB
(as existing in the Project and Library tree of the Control Builder) and to store the image
in the QVCS. When an object is checked-in, it becomes read-only and cannot be
modified.

As shown in the figure below, the Check-in dialog box displays the objects to be
checked-in. Comments for Check-in, Revision Type and the Revert Label(s) are entered
into the dialog box.  Clicking “OK” checks-in the selected objects.

Note: The Check-in option is only available to those objects that are new or checked-out.
The relevant menu items and toolbar icons are enabled only for objects that are not in
QVCS yet or were previously checked-out.
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Check In

Objects to be Checked In:

example_cascade
example_pid
CPM_Test
CEE_Test

Check In Details

Comments:

Checked in because Modifications were
made to these Strategies.

Revision Type

Minor Major

Apply Revert Label(s) to new version

OK Cancel

Revert Labels (Specify
One or more of these).
This is an optional Entry.

Revision Type (specify
Major or Minor). This is also
a mandatory field.The
default is "major".

 List of Objects to be
Checked In

Comments for Check In. It is mandatory that
the user specify a comment for check In.
Check In will not proceeed if comment is not
provided. Once Checked in, the the
comment cannot be changed.

Test Label1
Test Label2
Test Label3
Test Label4
Test Label5

Figure 7  Check-in Dialog Box
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Using the Check-in Dialog Box

Invoking the check-in dialog box

The check-In dialog box can be invoked from the QVCS Manager Main Window, Query
Window, and the Versions Window.   To invoke the check-in dialog:

• Select one or more new and/or checked-out object(s) -> from the Tools drop-down
menu, click on Check-in.

• Select one or more new and/or checked-out object(s) -> click the “Check In” icon on
the toolbar.

• Select one or more new and/or checked-out object(s) -> right-click and select Check-
in.

Object to be checked-in
• The list of objects selected for check-in is displayed in this list.

• The check-in details such as comments, revision type, and revert labels will be applied
to all the objects in the list.

Entering comments
• Enter the check-in comment in the Edit box provided.

• Check-in comments are mandatory.

Entering revision type

• Revision types can be specified as Major or Minor by selecting the appropriate check-
box.  The revision type will determine the increment of the version number.  The
version number is incremented with +1 for a major change and with +0.01 for a minor
change.  Major is the default.
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Revert Label

Step Action

1 All the existing user defined revert labels in QVCS are displayed in the list
with checkboxes against them.

2 As an option, select one or more revert labels for the check-in versions of the
object by selecting the checkboxes.  The selected labels are applied to the
new version of the objects.

3 If any of the selected labels have been applied on another version of any of
the selected objects for check-in, then a message that the labels will be
moved to the newer version of the object(s) is shown.

Move Revert Label ?

Yes No

The Revert Labels listed below have already been applied to previous
versions of objects in the Check In list. These labels will be moved from
the previous version to the new version for the objects.

Are you sure you want to move the following Revert Label (s) to new
version ?

Object Version Label

example_cascade

CPM_Test

1.2

1.1

Test_Label2

Test_Label4

4 If the Yes button is clicked, the check-in operation is initiated.

If the No button is clicked,  the check-in dialog will remain to allow
modifications to the revert labels.
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Check-out Dialog Box
Check-out marks a specific version of an object in the Qualification and Version Control
System as editable. Check-out takes the contents of a particular version from the
Qualification and Version Control System to the ERDB and subsequently to the Project
and the Library trees of the Control Builder.  The monitor side of the control builder is
not affected and will always show the version of the object that is loaded to the
controller.

The Check-out dialog box displays objects and the corresponding versions being
checked-out.  Optional check-out comments may be entered here.  Clicking the OK
button initiates the check-out.

Note: The Check-out option is only available to those strategies that are checked-in. The
relevant menu items and toolbar icons are enabled only for objects that were previously
checked-in.
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Check Out

Objects to be Checked Out:

example_cascade 1.5
example_pid 0.3
CPM_Test 3.5
CEE_Test 0.7

Check out Comments:

OK Cancel

Object Version Number

Optional Comments for
the Checkout operations
can be entered here.

Objects and the
Version Numbers being
Checked out

Figure 8  Check-out dialog box
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Using the Check-out Dialog Box

Invoking the check-out dialog box

The check-out dialog box can be invoked from the QVCS Manager Main Window,
Query Window and the Versions Window.  To invoke the Check-out Dialog:

• Select one or more object(s) -> in the Tools drop-down menu select Check-out.

• Select one or more object(s) -> click the Check-out icon in the toolbar.

• Select one or more object(s) -> right-click and select Check-out.

Entering comments
• Enter the check-out comment in the Edit box provided.

• Check-out comments are optional.
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Properties Dialog Box
To view the properties of any particular version of an object, invoke the Properties dialog
box.  The Properties dialog box permits changes to the qualification state and the revert
label for the currently selected version of the object. All other information in the dialog
box is read-only.

Properties

Name: example_cascade

Version: 3.5

Status: Checked Out

Comment: The user got tired up of repeatedly checking the object in.

Version Properties

Created By: Anand

Created On: 03/06/2002  10:45 AM

Last Modified By: Anand

Last Modified On: 03/25/2002  12:45 AM

OK Cancel

Change State...

Test_Revert_Label_1
Test_Revert_Label_2

5
4
3
2
1

Applied Labels

Apply/Remove Label...

Current State:

Qualification State Configuration

Revert Label Configuration

Implemented

Figure 9  Properties Dialog Box
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Using the Properties Dialog Box

Invoking the properties dialog box

The Properties dialog box can be invoked from the Manager Main window, Manager
Query Window and the Versions Window in the QVCS Manager.   To invoke the
Properties dialog box:

• Select a particular version in the window -> in the View drop-down menu, select
Object Properties.

• Select a particular version in the window -> select the Object Properties icon from the
toolbar.

• Select a particular version in the window -> right-click and select Object Properties.

Version properties

Version specific properties like object name, version, status, comment, object creation
details, and modification details are shown in the Version Properties field.

Change qualification state
• The current qualification state for the object version is displayed in the edit box.

• To change the qualification state click the Change State button, invoking the Change
Qualification State dialog box.

Revert labels
• The list of current applied revert labels for the object version are displayed in the list.

• To apply/remove revert labels click the Apply/Remove Label button., invoking the
Apply/Remove Labels to Version dialog.
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Properties in Control Builder
The Properties Dialog also forms a part of the Control Builder Configuration Forms for
Tagged Objects as shown in the figure below.

SYSTEM:CONTROLMODULE Block, example_cascade - Parameters [Project]

Main VersionServer History Server Display

OK Cancel HelpShow Parameter Names

Name: example_cascade

Version: 3.5

Status: Checked Out

Comment: The user got tired up of repeatedly checking the object in.

Version Properties

Created By: Anand

Created On: 03/06/2002  10:45 AM

Last Modified By: Anand

Last Modified On: 03/25/2002  12:45 AM

Change State...

Test_Revert_Label_1
Test_Revert_Label_2

5
4
3
2
1

Applied Labels

Apply/Remove Label...

Current State:

Qualification State Configuration

Revert Label Configuration

Implemented

Figure 10  Properties dialog as part of Control Builder Configuration Forms
for Tagged Objects
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Qualification State Configuration Dialog Box
In the Version Control System, the qualification state refers to the stages a control
strategy may pass through as part of the qualification process for the strategy. For
example, Implemented, Testing, Released, and Decommissioned may be defined as states
that are important for tracking the control strategy qualification process. The control
strategy would go through these different phases as it is developed and refined. It may be
necessary for the control strategy to go through certain phases for it to be termed
“qualified”. For example, it may be necessary that the control strategy be “Implemented”,
that “Testing” be performed on it and that it be “Released”.

The Qualification State configuration dialog provides an option to define the
configuration states and to manage the qualification life cycle transition. Administrative
privilege is required to access this dialog box.   The dialog box can be used to add,
modify and delete the configuration states. Qualification life cycle transition states can be
specified and electronic signature requirements defined for the state transitions.
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Figure 11  Qualification Life Cycle Configuration

Qualification Life Cycle States Grid
The grid shows the list of:

• defined qualification states – stage that the control stratgey passes as part of
customer’s qualification process

• the corresponding fallback states – state that an object is placed when it is checked in
the VCS.

• restricted signing states – is only used if signing is required to make a state transition,
and

• load to controller allowed options – means object in the project tab has been loaded
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The rows are sorted in the order they are defined. For example, if the state Implemented
is specified, then Testing, the state Implemented will occupy the first row followed by
the state Testing in the second row.

Using the Qualification State Configuration Dialog Box

Adding qualification state

Step Action

1 Click on the Add button in the Qualification State Configuration dialog.

2 The dialog prompt to enter the new Qualification State will be displayed.

Add New Qualification State

OK Cancel

Qualification State:

Fallback State: Select Fallback state

Restricted Signing : Select restricted signing

Load to controller allowed

Enter new
Qualification
State

List of Fallback States. The
combo will list all the
Qualification states currently
defined..  including the new
one The combo will list all the

Qualification states defined in
the VCS

Load to controoler allowed. If
checked the value is "Yes"
else "No"

3 Enter the new qualification state in the edit box provided.

4 Select the Fallback State. The combo lists all the Qualification states
currently defined in the QVCS, including the new state.

5 Select the restricted signing state. The combo lists all the Qualification states
currently defined in the QVCS.

6 Check/Uncheck the Load to Controller Allowed check-box to determine
whether the load to controller will be allowed.

7 Click the OK button to add the qualification state to QVCS.  Select Cancel to
discard the operation.

8 After the OK button is selected, the Qualification Life Cycle States grid is
refreshed to reflect the addition.
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Modifying Qualification State

Step Action

1 Click the Modify button in the Qualification State Configuration dialog box.

2 The current highlighted state will be selected for modifying, and the Modify
Qualification State dialog box will appear.

Modify Qualification State

Implemented

OK Cancel

Qualification State:

Fallback State: Implemented

Restricted Signing : None

Load to controller allowed

Modify
Qualification State

List of Fallback States. The
fallback state of the
modifying state will be
selected in the combo.

The combo will list all the
Qualification states currently
defined.

The restricted signing of the
modifying state will be
selected.
The combo will list all the
Qualification states defined in
the VCS

Load to controoler allowed. If
checked the value is "Yes"
else "No"

• The edit box shows the Qualification State that is being modified.

• The Fallback State combo-box will select the fallback state of the
qualification state being modified.

• The Restricted Signing combo-box will select the restricted signing state
of the qualification state that is being modified.

• The Load to Controller Allowed check-box is checked/unchecked
depending on the setting of the qualification state being modified.

3 After editing the fields, click the OK button to save the changes to QVCS.
Click the Cancel button to discard changes.

4 After the OK button is selected, the Qualification Life Cycle States grid is
refreshed to reflect the modifications.
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Deleting Qualification State

Step Action

1 Click the Delete button in the Qualification State Configuration dialog box.

2 The current highlighted row is selected for deletion.

3 The Delete Qualification State box will appear to confirm the delete operation.

Delete Qualification State

Yes No

Are you sure you want to Delete the Qualificaiton State 'Implemented' ?

Click on Yes to delete the Qualification State from the QVCS.  Click on No to
discard the operation.

4 If the Yes button is selected the Qualification Life Cycle States and
Qualification Life Cycle Transition grid are refreshed to reflect the deletion.

Qualification life cycle transitions grid

• The defined Qualification States are shown in the first row and the first column of the
grid.

• There are as many rows and columns as Qualification States defined.

• An electronic signature can be configured for state transitions between the various
states.  For example, configuring an electronic signature is desired for transition from
Implemented to Testing, choose the cell with the row corresponding to the
Implemented state and the column corresponding to the Testing State.  Then click the
Configure Transition Requirements button.

• State transitions for diagonal elements in the grid are not possible.   These diagonal
cells are grayed out in the grid and editing is not possible in these cells.
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Configuring state transition requirements

Step Action

1 Select the cell the Transition Requirement will be configured for.

2 Click the Configure Transition Requirement button to invoke the Configure
Transition Requirements dialog box.  The current state transition requirement
values will be shown.

The signature requirement for the state transition can be specified from the
following four options:

1. Not Allowed - the state transition is not allowed between states.

Configure Transition Requirements

OK Cancel

User ID Select User

Group Select Group

Anybody

Signature Requirement for State Transition

Not allowed

Electronic signature required

Signature Requirement for State Transition

2. Anybody - any user can change transition state.
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Step Action

Configure Transition Requirements

OK Cancel

User ID Select User

Group Select Group

Anybody

Signature Requirement for State Transition

Not allowed

Electronic signature required

Signature Requirement for State Transition

3. User ID - only the specified user can change transition state. The list of
users is shown in the combo-box.  Select one of the users from the list
as shown below.

Configure Transition Requirements

OK Cancel

User ID

Group

Anybody

Signature Requirement for State Transition

Not allowed

Electronic signature required

Signature Requirement for State Transition

Select User

Anand
Jeff
Mark
Ravi
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Step Action

4. Group - only the users belonging to the specified group can change
transition states. The list of groups is shown in the combo-box.  Select
one of the groups from the list as shown below.

Configure Transition Requirements

OK Cancel

User ID Select User

Group

Anybody

Signature Requirement for State Transition

Not allowed

Electronic signature required

Signature Requirement for State Transition

Select Group

Administrators
Semi-Administrators
Users

3 Check the Electronic Signature Required checkbox to require an electronic
signature when the qualification state transition occurs. This checkbox is
active only when a state transition is allowed, i.e. the state transition can be
performed by Anybody, User ID, Group.
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Step Action

Configure Transition Requirements

OK Cancel

User ID Select User

Group Select Group

Anybody

Signature Requirement for State Transition

Not allowed

Electronic signature required

Signature Requirement for State Transition
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Change Qualification State Dialog Box
The Change Qualification State dialog box is invoked as part of Qualification state
transitions explained in previous section, to accommodate transitioning for one
qualification state to another.  The object, its current version and qualification state are
displayed with an option to change the qualification state.  The combo box  will only list
those qualification states that are allowed according to the transition matrix.

Change Qualification State

OK Cancel

Object: example_cascade

Version: 1.0

Current Qualification State: Implemented

Change Qualification State To:

Figure 12  Change Qualification State dialog box
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Change Qualification State

Object: example_cascade

Version: 1.0

Current Qualification State: Implemented

Change Qualification State To:

OK CancelImplemented
Testing
Released
Withdrawn

Figure 13  Change Qualification State dialog box with List expanded
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Using the Change Qualification State Dialog Box

Invoking change Qualification State

The Change Qualification State dialog box is invoked from the Manager Main Window,
Query Window, Versions Window and Properties Dialog.   To invoke the dialog box::

• select a particular object version -> from the Tools drop-down menu, select Change
Qualification State, or

• select a particular object version -> right-click and select Change Qualification State,
or

• the dialog can also be invoked from the Properties dialog box by clicking the Change
State... button, or

• using the configuration forms in Control Builder.

Changing the qualification state

Step Action

1 Select one of the Qualification states listed in the combo box.

2 Click the OK button.
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Configure Electronic Signature Dialog Box
For some Qualification state transitions, the QVCS may require verification of the action
by validating the electronic signature associated with the operation. To validate the
Electronic signature, the Electronic Signature component is invoked, requesting the User
Name and Password.  These must be entered within the number of attempts and time
allowed.

Figure 14  Electronic Signature dialog box

The time-out period can be configured using the Configure Electronic Signature dialog
box shown below.  Signature Requirements for Revert Operations can also be configured
with the help of this dialog box.
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Configure Electronic Signature

None

3

OK Cancel

User ID Select User

Group Select Group

None

Signature Requirement for Revert Operation

Electronic Signature Time-out period (minutes):

Number of Retries Allowed:

Specify the Electronic
Signature Time-out
period here. 0 implies
no time-out

Figure 15  Configure Electronic Signature dialog box
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Using the Electronic Signature Dialog Box

Invoking the configure electronic signature dialog box

QVCS Administrator privileges are required to configure Electronic Signatures.  This
option is enabled during the launch of QVCS Manager when the User ID supplied by
Control Builder confirms Administrator privileges.  Administrator privileges are
confirmed, the Electronic Signature Configuration Utility can be invoked.  To invoke the
utility from the QVCS Manager main menu:

Step Action

1 From the Tools drop-down menu, select Administration -> Configure
Electronic Signature.

2 Configure the time-out period, number of retries and signature requirements
for Revert operations.

• Electronic Signature Time-out Period:  Enter the time-out period in
the edit box provided, specified in minutes.  The spin control can be used
to increase/decrease the time-out period.  The minimum value for the
time-out period is None (0), indicating no time-out.

• Number of Retries:  Enter the number of retries in the edit box
provided.  The spin control can be used to increase/decrease the
number of retries.  The minimum value for the number of retries is 0,
requiring the correct user ID and password to be entered correctly in the
very first attempt.

• Signature Requirement for Revert Operation:  Revert Operations can
be specified to require authentication using three options:  None, User
ID, and Group.

− The default is None, allowing anyone to perform Revert Operations with
no signature required.

− The User ID option enables a List Box to specify who can authenticate
Revert Operations with a signature required.

− The Group option enables the List Box to specify a group the user must
belong to in order to authenticate Revert Operations.  An electronic
signature will be required.

3 Click OK when complete.
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Revert Level Maintenance Dialog Box
Revert Label Maintenance is used to add, delete, and modify revert labels. The Revert
Label maintenance dialog displays a list of the current labels and allows for their
modification.

Revert Label Maintenance

VCS_TEST_LABEL1

VCS_TEST_LABEL2

VCS_TEST_LABEL3

VCS_TEST_LABEL4

VCS_TEST_LABEL5

VCS_TEST_LABEL6

VCS_TEST_LABEL77

6

5

4

3

2

1

Existing Revert Labels Add

Modify

Delete

Close

10
9
8

Figure 16  Revert Label Maintenance dialog box
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Using the Revert Level Maintenance Dialog Box

Invoking the revert level maintenance dialog box
To invoke the Revert Label Maintenance dialog box:

• From the Tools drop-down menu, select Revert Labels -> Revert Label Maintenance.

• Select Labels -> Revert Label Maintenance from the drop-down context menu.

• Click the Label Maintenance… button from the Apply/Remove Revert Labels dialog
boxes.

Existing revert labels list
• All revert labels defined in the QVCS are listed in alphabetical order.

• The list of revert labels is sorted by clicking the “Existing Revert Labels” heading.
Sort order toggles between ascending/descending.

• Only a single label can be selected from the list for delete and modify operations.

Adding a new revert label

Step Action

1 Click the Add button in the Revert Label Maintenance dialog box to invoke
the Add Revert Label dialog box.

Add New Revert Label

OK Cancel

Enter the New Label Name:

2 In the edit box, enter the new label to be added to the list of QVCS revert
labels.  The new label name must be unique, at least one character in length
and contain no spaces.  It is not case sensitive.

3 Click the OK button to add the new label to the list of QVCS revert labels.
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Deleting a revert label

Step Action

1 Select a revert label in the “Existing Revert Labels” list.

2 Click the Delete button in the Revert Label Maintenance dialog to invoke the
Delete Revert Label Confirmation dialog box.

Delete Revert Label?

Yes No

Are you sure you want to Delete the Label
VCS_Test_Label5 ?

3 Click the “Yes” button.  The selected revert label is removed from the list of
QVCS revert labels.

Modifying a revert label

Step Action

1 Select a revert label in the Existing Revert Labels list.

2 Click the Modify button in the Revert Label Maintenance dialog to invoke the
Modify Revert Label dialog box.

Modify Revert Label

VCS_TEST_LABEL1

OK Cancel

Label:

3 The selected revert label from the “Existing Revert Labels” list is shown in the
edit box, where it may be edited.  The new label name must be unique, at
least one character in length, and contain no spaces.

4 Click the OK button to modify the label.
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Apply/Remove Labels to Version Dialog Box
Apply/Remove Revert Labels to Version dialog box displays the object and its version
number. The list box on the left displays the Revert Labels assigned to the existing
version, and the list box on the right shows all the Revert Labels in the Qualification and
Version Control System.

Apply/Remove Revert Labels to Version

VCS_LABEL1
VCS_LABEL2
VCS_LABEL3
VCS_LABEL4
VCS_LABEL5
VCS_LABEL6
VCS_LABEL7
VCS_LABEL8
VCS_LABEL9

All Revert  Labels:

Add >

< Remove

VCS_USER_LABEL1
VCS_USER_LABEL2

Applied Revert Labels (for
the version):

Object: example_cascade

Version: 1.0

References... >>CancelOK Label Maintenance...

Figure 17  Apply/Remove Revert Labels to Version
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Using Apply/Remove Labels to Version Dialog Box

Invoking the apply/remove revert labels to version dialog box

The dialog box can be invoked from the Manager Main Window, Query Window and the
Versions Window. To invoke the dialog box:

• Select a particular version in the window and in the Tools drop-down window, select
Revert Labels -> Apply/Remove -> To Selected Versions.

• Select a particular version in the window, right-click and select Labels -> Apply/Remove
-> To Selected Versions.

• The selected object and its version number are displayed.

• There are two list boxes:

− The All Revert Labels (left side) list box shows all the Revert Labels in the
Qualification and Version Control System.

− The Applied Revert Labels (right side) list box displays the Revert Labels assigned
to the existing version.

• The labels applied to the object version are not shown in the “All Revert Labels” list
box.

Adding a revert label to the existing version

• To add another Revert Label to the existing version, select a revert label in the All
Revert Labels list box and click the Add button.

• Multiple revert labels can be selected in the list using the <Ctrl> and <Shift> keys.

• When the Add button is selected, the label(s) is removed from the All Revert Labels
list box and added to the Applied Revert Labels list box.

• The added labels are not applied to the object version at this time.

Removing a revert label from the existing version

• To remove revert label(s), select the existing revert label(s) in the Applied Revert
Labels list box and click the Remove button.

• Multiple revert labels can be selected in the list using the <Ctrl> and <Shift> keys.

• When the Remove button is selected, the label(s) is removed from the Applied Revert
Labels list box and added to the All Revert Labels list box.
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• The added labels are not removed from the object version at this time.

Applying/removing labels on the object version
• Click the OK button to apply/remove Revert Labels to the object version.

• If any labels are removed from other versions of the objects currently in the Control
Builder project and library trees then the confirmation dialog will display a list of
these objects indicating version number and assigned label.

Note: The Labels are applied/removed only when the OK button is clicked,  not when
the Add or Remove button is clicked.

Remove Revert Label ?

Yes No

You have choosen to remove the following Revert Labels from the object
version.

Are you sure you want to remove the following Revert Label (s) ?

Object Version Label

example_cascade

example_cascade

1.2

1.2

Test_Label2

Test_Label4

Figure 18  Remove Revert Label Confirmation Dialog

Label maintenance

Step Action

1 Click the Label Maintenance… button to bring up the Revert Label
Maintenance dialog box.

2 Add/delete/modify the existing QVCS revert labels.

3 On return from the Label Maintenance dialog box, the existing lists of labels
are refreshed to reflect the changes made to the revert labels.
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Viewing references

• Click the References…>> button to bring up the modified Apply/Remove Revert
Labels dialog box.

Apply/Remove Revert Labels to Version

VCS_LABEL1
VCS_LABEL2
VCS_LABEL3
VCS_LABEL4
VCS_LABEL5
VCS_LABEL6
VCS_LABEL7
VCS_LABEL8
VCS_LABEL9

All Revert  Labels:

Add >

< Remove

VCS_USER_LABEL1
VCS_USER_LABEL2

Applied Revert Labels (for
the version):

Object: example_cascade

Version: 1.0

example_cascade 1.5
example_pid 0.3
CPM_Test 3.5
CEE_Test 0.7

Object Version Number

Other Objects Referencing this object

<< References...CancelOK Label Maintenance...

Figure 19  Apply/Remove Revert Label Dialog showing Objects Referencing
the selected object version.

• A list of all other objects, and their versions, that refer the selected object version are
displayed in a list.

• The References…>> button text reverts to << References….

• Click << References… button to restore the dialog box in Figure 17.
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Apply/Remove Revert Labels to Contained Dialog
Box

The Apply/Remove Revert Labels to Contained dialog box displays the selected Object
and its contained objects, and the current versions of these objects in the ERDB. Also
shown are the lists of existing Revert Labels for the object, its contained objects, and all
the Revert Labels in the QVCS database.  In this context, contained refers to hierarchical
objects like Hierarchical Control Modules and to contained through assignment like
objects that are assigned to a specific controller.

For the example given below, when a Revert Label is applied, it is applied to CPM_Test
version 1.5, CEE_Test version 1.9 and example_cascade version 0.8.  If any label(s) is
removed, the selected Revert Label(s) is disassociated from any versions it was assigned
to. For example, if the QVCS_USER_LABEL1 was assigned to CPM_Test version 1.2,
CEE_Test version 1.0 and example_cascade version 0.9, it is disassociated from those
versions of the objects.

Apply/Remove Revert Labels to Contained

VCS_LABEL1
VCS_LABEL2
VCS_LABEL3
VCS_LABEL4
VCS_LABEL5
VCS_LABEL6
VCS_LABEL7
VCS_LABEL8
VCS_LABEL9

All Revert  Labels:

Add >

< Remove

VCS_USER_LABEL1
VCS_USER_LABEL2

Applied Revert Labels:

CancelOK Label Maintenance...

Contained Objects to which Label would also be applied:

CEE_Test 1.9
example_cascade 0.8

Object Version Number

Object(CPM_Test) and its
contained Objects
(CEE_Test and
example_cascade) and
its versions. This is a
read-only list.

Object: CPM_Test

Version: 1.5

Figure 20  Apply/Remove Labels to Contained dialog box
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Using Apply/Remove Revert Labels to Contained Dialog
Box

Invoking the apply/remove revert labels to contained dialog box

The dialog box can be invoked from the Manager Main Window, Query Window and the
Versions Window.  To invoke the dialog box:

• Select a particular version in the window and in the Tools drop-down menu, select
Revert Labels -> Apply/Remove -> All Contained Objects.

• Select a particular version in the window and right-click, selecting Labels ->
Apply/Remove -> All Contained Objects.

Applying/removing the revert labels to contained objects

• The selected object and its contained objects with their version numbers are displayed
in a list box below the label: Objects to which the labels would be applied.

• There are two list boxes

− The All Revert Labels (left side) list box shows all the Revert Labels in the
Qualification and Version Control System.

− The Applied Revert Labels (right side) list box displays the Revert Labels assigned
to the selected object and its contained objects.

• The labels, which are applied to the selected object and its contained objects version,
are not shown in the All Revert Labels list box.

• If any labels are removed from other versions of the objects currently in the Control
Builder project and library trees then the confirmation dialog will display a list of
these objects indicating version number and assigned label.

Adding a revert label to existing objects

• To add another Revert Label to existing objects, select a revert label in the All Revert
Labels list box and click the Add button.

• Multiple revert labels can be selected in the list with the help of the <Ctrl> and
<Shift> keys.

• When the Add button is selected, the label(s) is removed from the All Revert Labels
list box and added to the Applied Revert Labels list box.

• The added labels are not applied to the contained objects at this time.
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Removing a revert label from existing objects

• To remove revert label(s), select existing revert label(s) in the Applied Revert Labels
list box and click the Remove button.

• Multiple revert labels can be selected in the list with the help of the <Ctrl> and
<Shift> keys.

• When the Remove button is selected, the label(s) is removed from the Applied Revert
Labels list box and added to the All Revert Labels list box.

• The removed labels are not removed from the contained objects at this time.

Applying/removing labels of contained objects
• Click the OK button to apply/remove Revert Labels to the contained objects.

• If any labels are removed from other versions of the objects currently in the Control
Builder project and library trees then the confirmation dialog will display a list of
these objects indicating version number and assigned label.

Label maintenance

• Click the Label Maintenance… button to open the Revert Label Maintenance dialog
box.  Add/delete/modify the existing QVCS revert labels.

• After closing the Label Maintenance dialog box, the existing lists of labels are
refreshed to reflect the changes made to the revert labels.
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Apply/Remove Labels to All Dialog Box
The Apply/Remove Revert Labels to All dialog box is used to apply/remove Revert
Labels to all the objects in ERDB. This dialog box displays what can be done with this
Interface. Applying a Revert Label to All is chosen, the current version of all the objects
in ERDB would be associated with the selected Revert Label. As shown in the figure
below, the edit box on the left displays the existing Revert Label(s) defined in the
Qualification and Version Control System database. If one of these Revert Labels is
selected and Remove option chosen, the versions of the objects associated with this
Revert Label are disassociated from the Revert Label.

Apply/Remove Revert Labels to All

VCS_LABEL1
VCS_LABEL2
VCS_LABEL3
VCS_LABEL4
VCS_LABEL5
VCS_LABEL6
VCS_LABEL7
VCS_LABEL8
VCS_LABEL9

All Revert  Labels:

Add >

< Remove

VCS_USER_LABEL4

Applied Revert Labels:

CancelOK Label Maintenance...

You can apply Revert Labels to or Remove Revert Labels from the current versions
of all the objects in the Project and Library trees in Control Builder.

Figure 21  Apply/Remove Revert Labels to All
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Using Apply/Remove Revert Labels to All Dialog Box

Invoking the apply/remove revert labels to all dialog box

This dialog box can be invoked from the Manager Main Window, Query Window and
the Versions Window.  To invoke the dialog box:

• Select a particular version in the window and from the Tools drop-down menu, select
Revert Labels -> Apply/Remove -> All Objects.

• Select a particular version in the window and right-click, selecting Labels ->
Apply/Remove -> All Objects.

Applying/removing revert labels to all
There are two list boxes:

• The All Revert Labels (left side) list box shows all the Revert Labels in the
Qualification and Version Control System.

• The Applied Revert Labels (right side) list box displays the Revert Labels assigned to
all the objects in the project and library trees in Control Builder.

The labels, which are applied to all the objects in the project and library trees in Control
Builder, are not shown in the “All Revert Labels” list box.

If any labels are removed from other versions of the objects currently in the Control
Builder project and library trees then the confirmation dialog will display a list of these
objects indicating version number and assigned label.

Adding a revert label to all

• To add another Revert Label to the objects, select a revert label in the “All Revert
Labels” list box and click the Add button.

• Multiple revert labels can be selected in the list with the help of the <Ctrl> and
<Shift> keys.

• After selecting the Add button, the label(s) is removed from the All Revert Labels list
box and added to the Applied Revert Labels list box.

• The added labels are not applied to the objects in the Control Builder project and
library trees at this time.
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Removing a revert label to all

• To remove revert label(s), select existing revert label(s) in the Applied Revert Labels
list box and click the Remove button.

• Multiple revert labels can be selected in the list with the help of the <Ctrl> and
<Shift> keys.

• After selecting the Remove button, the label(s) is removed from the Applied Revert
Labels list box and added to the All Revert Labels list box.

• The removed labels are not removed from the objects in the Control Builder
project and library trees at this time.

Applying/removing labels to all in Control Builder project and library trees

• Clicking  the OK button will apply/remove Revert Labels to the objects in the Control
Builder project and library trees.

• If any labels are removed from other versions of the objects currently in the Control
Builder project and library trees then the confirmation dialog will display a list of
these objects indicating version number and assigned label.

Label maintenance

• Click the Label Maintenance… button to bring up the Revert Label Maintenance
dialog.  This may be used to add/delete/modify the existing QVCS revert labels.

• After closing the Label Maintenance dialog box, the existing lists of labels are
refreshed to reflect the changes made to the revert labels.
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Revert to a Version Dialog Box
The Revert to a Version dialog box displays the object name, its ERDB version and
allows a revert version to be selected.

• In this scenario, the dialog includes a message stating that the current version in
ERDB is replaced with the selected version.

• The dialog displays the object name and its ERDB version.

• The Version list (left side) box displays all versions of the object.

• The Revert labels (right side) list box displays all labels from the selected version in
the Version list box.

Revert to a Version

Object : example_cascade

2.2
2.1
2.0
1.4
1.3
1.2
1.1

>
Version Number

0.5
0.2

1.0

REVERT_LABEL1
REVERT_LABEL2

Revert Labels

Revert labels applied to
selected version

OK Cancel

Version : 2.2

The current version of the object (shown below) in the Project and
Library trees in Control Builder is replaced with the chosen Revert
version.

Figure 22  Revert to a Version Dialog Box

Using the Revert to a Version Dialog Box

Invoking the revert to a version dialog box
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This dialog box can be invoked from the Manager Main Window, Query Window and
the Versions Window.  To invoke the dialog box:

• From the Tools drop-down box, select -> Revert Labels -> Revert -> Revert to
Version.

• Select the Revert To Version icon from the toolbar.

• Select Revert Labels -> Revert -> Revert To Version menu item from the drop-down
context menu in all the QVCS Manager windows.

Reverting to a version

• Select the version from the Version list box. In this scenario, the current version of the
object as existing in ERDB is replaced by the selected Version.  This action will not
affect the version of the object on the monitor side of Control Builder.

• Clicking the OK button will initiate the reversion process
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Revert to Label Dialog Box
The Revert to Label dialog box includes a message stating that all the current object
versions in ERDB will be replaced with the versions of the objects under the chosen
Revert Label.

In this example, object1 version 2.0, object2 version 2.9 and object3 version 0.9 are
assigned a revert label RVRT_LBL1.   When this dialog is invoked and Revert to Label
RVRT_LBL1 is chosen from the Combo Box, the current versions of the objects object1,
object2 and object3 in ERDB are replaced with RVRT_LBL1 versions; namely version
2.0, version 2.9 and version 0.9 for object1, object2 and object3 respectively. The
Control Builder may have other objects also apart from the three mentioned above. Those
objects are left untouched.

Revert To Label

Choose Label to Revert To: Select Label

OK Cancel

All the current object versions in the Project and Library tree in Control
Builder would be replaced with the version in Version Control System
under the specified Revert Label.

Figure 23  Revert to Label Dialog Box
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Using the Revert to Label Dialog Box

Invoking the revert to label dialog box

This dialog box can be invoked from the Manager Main Window, Query Window and
the Versions Window.  To invoke the dialog box:

• From the Tools drop-down menu, select Revert Labels -> Revert -> Revert To Label.

• Select Revert Labels -> Revert -> Revert To Label menu item from the drop-down
context menu in all the QVCS Manager windows.

Reverting to a label

• Provides information that all the current object versions in ERDB would be replaced
with the versions of the objects under the chosen Revert Label.

• A Revert Label can be chosen using the Combo box, which lists all the revert labels
defined in the QVCS as shown below.

Revert To Label

Choose Label to Revert To:

OK Cancel

All the current object versions in the project and Library tree in Control
Builder would be replaced with the version in Version Control System
under the specified Revert Label.

Select Label

Revert_Label1
Revert_Label2
Revert_Label3

• Click the OK button to initiate the reversion process
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Relaxed Loading Support for QVCS

Relaxed Load Function

About relaxed load function

If your are using a licensed Qualification and Version Control System (QVCS)
application in your Experion PKS system running software version R101 or higher, the
relaxed load function lets you load an object that has not yet been checked in to QVCS to
a controller.

ATTENTION

Once an object is "checked in" to QVCS, it must pass the QVCS loading
restrictions before it can be loaded to a controller.

Typical relaxed load functional scenario

The following table outlines the stages in a typical development and testing scenario that
uses the relaxed load function. This scenario assumes that you are familiar with the
Control Builder application, have a QVCS license, and are running Experion PKS
software version R101 or higher.

Stage Description

1 Create the execution environment.

2 Create a control strategy

3 Assign the control strategy to the execution environment.

4 Load the execution environment and the control strategy to the controller.

TIP

This is considered a relaxed load, since neither the execution environment
nor the control strategy is checked in to QVCS.

5 Test the control strategy to determine if it is executing correctly.

6 If control strategy executes correctly, go to Stage 7.

If control strategy does not execute correctly, make changes as required and
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Stage Description
repeat Step 5.

7 Check in the control strategy and execution environment to QVCS.

8 Make any qualification state transitions as defined by the site's Standard
Operating Procedure (SOP).

ATTENTION

The user is responsible for making sure that the process control system that
is loaded has been qualified and that it contains no non-QVCS objects. The
Query dialog of the QVCS Manager provides a Not in QVCS query and a
Loaded, not in QVCS query, so users can quickly determine the status of
their system.

9 Load the execution environment and control strategy with the QVCS version
in the desired qualification state to the controller.

10 If problems exist, use QVCS Manager to check out the problem object, make
the necessary change in Control Builder, and check it into QVCS. With object
in required qualification state, load it to the controller.

Initiating queries for non-QVCS objects

The following table outlines the typical steps for checking the state of the control system
for any non-QVCS objects. The illustrations used are for example purposes only.

Step Action

1 Click Tools->QVCS Manager to launch the Manager.

2 Click the Query tab.

3 Click the down-arrow button to the right of Query on field and select QVCS
State from the shortcut menu.

4 Click the down-arrow button to the right of Value field and select Not in
QVCS from the shortcut menu.

5 Click the List button and view the results of the query in the dialog.
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Step Action

6 Click the down-arrow button to the right of Value field and select Loaded, not
in QVCS from the shortcut menu.

7 Click the List button and view the results in the dialog.
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Step Action

TIP

You can use common Windows-based shortcut keystroke functions such as
Shift + Click and Ctrl + Click to select all or only selected objects in the list to
be checked in at one time.

10 This completes the steps for using QVCS queries to find non-QVCS objects
in your control system.

Making multiple object qualification state transitions

The following table outlines the typical steps for making qualification state transitions for
multiple objects. The illustrations used are for example purposes only.

Step Action

1 Click Tools->QVCS Manager to launch the Manager.

2 Click the Query tab.

3 Click the down-arrow button to the right of Query on field and select
Qualification State from the shortcut menu.

4 Click the down-arrow button to the right of Value field and select Default
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Step Action
State or other desired state from the shortcut menu.

5 Click the first object in the dialog list and Shift + Click the last object in the list
to select all the objects.

6 Click Tools->Change Qualification State or right click and select Change
Qualification State from the shortcut menu.

7 Click the down-arrow button to right of Change Qualification State To field
and select the desired state from the shortcut menu.
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Step Action

8 Click the OK button to initiate qualification state change validation.

ATTENTION

• If any validation fails, none of the qualification states for any of the object
versions will be updated. Check displayed error message(s) to identify the
source of the validation failure(s).

• If an electronic signature is configured for the requested transition, a
single signature dialog is displayed and the same signature is applied to
all of the transitions. A log entry, including applicable associated
electronic signature log entry, is generated for each object in the list.

9 The qualification states for the selected objects are changed.

10 This completes the procedure.



R210 Experion PKS Qualification and Version Control User Guide 85
10/04 Honeywell

Version Difference Tool (Diff Tool)
The Qualification and Version Control System (QVCS) provides a method for tracking
and comparing changes that are made to control strategies between versions.  The QVCS
Version Difference Tool (Diff Tool) can be used to view and compare differences
between versions of a QVCS object. The Diff Tool functionality is included when a
QVCS license is purchased.

A difference operation is typically performed on two versions of single object. The Diff
tool shows the differences between the two versions, highlighting additions to the
strategy in green, modifications in blue, and deletions in red.

The Diff Tool also provides functionality for searching for next/previous difference,
finding text in the version window, printing and help.
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Version Control System Diff Tool - [example_cascade]
File   Edit   View   Navigate   Help

Version - 1.2 Version - 1.1

Figure 24  Diff Tool User Interface
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Figure 25  Diff Tool – Difference Between Two Versions
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Diff Tool Toolbar

The toolbar provides fast and easy access to the some of the frequently used
functionality. Below is the list of toolbar items and the functionality associated with it.
The user could click on the toolbar button and invoke the function.

Table 2  Diff Tool Toolbar

Toolbar
Icon

Tool Tip Menu Item

First difference Navigate->First difference

Previous difference Navigate->Previous difference

Next difference Navigate->Next difference

Last difference Navigate->Last difference

Find Edit->Find

Help Help->Knowledge Builder
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Using the Diff Tool

Invoking the Diff Tool

The Diff Tool is invoked from the QVCS Manager by selecting the menu items:
Compare -> With Previous Version/With Another Version/With Monitor Version/With
Checked Out Version.

• The version number being compared is shown in the title of the version window.

• If the version being compared is the Monitor version, then the title will display the text
Version – Monitor.

• If the version being compared is the Checked-out version, then the title will display
the text Version –Checked-out.

Reading the differences

• The block items modified between the versions are shown in BLUE with the text M
next to them.

• The block items added between the versions are shown in GREEN with the text A
starting at the block definition.

• The block items deleted between the versions are shown in RED with the text D
starting at the block definition.

• If the versions being compared are identical, then a dialog indicating this situation is
displayed.

Scrolling the difference windows
• There is one scroll bar for scrolling.

• Both windows are synchronized with respect to the scroll bar position.  For example,
change in the scroll bar position will produce an equal delta in both the windows.

Resizing an individual version window
• A splitter bar separates the two version windows.

• Windows are resized using the splitter bar.
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Printing the difference output

To print the difference output, select the print button.  If printing to a non-color printer,
only the M, A, and D markings will denote the changes between versions.
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QVCS Troubleshooting

Error Handling Overview
The error message box displays what operation has failed.  The contents of the error
message box vary depending on the context.

Version Control System

The object is under control of the VCS, but is not currently checked in
[ERR_VCS_NOTCHECKEDIN(6L.101.10139)]

The Checkin operation failed. The following errors were encountered while
performing the operation.

Errors:

OK

Figure 26  Error Message Box
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QVCS Error Messages

QVCS configuration tips
• Configure users before deploying and using the QVCS system.

• Define and configure the qualification lifecycle before developing objects, avoid
making changes to the lifecycle as much as possible (define behavior on deleting
adding etc of qualification states).

• If the QVCS system is used in a non-regulated industry and the main goal is to have
version control of objects then define only one qualification state, for example the
‘default’ state and allow this state to be loaded to the controller. This will basically
eliminate the qualification lifecycle.

• A double signature for a certain qualification state transition as part of the lifecycle
definition can be accomplished by defining two subsequent qualification states. Each
state change to be performed by a different user/group with electronic signature
enabled. The restricted signing state of the second qualification state (which
corresponds with the second signature) should be set to the qualification state of the
first qualification state signature (which corresponds with the first signature).
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