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About This Document 
This document describes how to use the Enterprise Model Builder application to build and 
administer the Enterprise Model in Experion or EBI systems. The Enterprise Model provides a 
means of organizing the system around the key entities in the customer’s enterprise such as assets, 
material, activities and people. 
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Symbol Definitions 
The following table lists those symbols used in this document to denote certain conditions. 
 

Symbol Definition 
 

 
 

 
ATTENTION: Identifies information that requires special 
consideration.  

 

 

 
TIP: Identifies advice or hints for the user, often in terms of 
performing a task.  

 

 

 
REFERENCE -EXTERNAL: Identifies an additional source of 
information outside of the bookset.  

 

 

 
REFERENCE - INTERNAL: Identifies an additional source of 
information within the bookset.  

 
CAUTION 

 
Indicates a situation which, if not avoided, may result in equipment 
or work (data) on the system being damaged or lost, or may result in 
the inability to properly operate the process. 

  

 
 

 
CAUTION: Indicates a potentially hazardous situation which, if not 
avoided, may result in minor or moderate injury. It may also be used 
to alert against unsafe practices.  

CAUTION symbol on the equipment refers the user to the product 
manual for additional information. The symbol appears next to 
required information in the manual. 

 

 
 

 
WARNING: Indicates a potentially hazardous situation, which, if not 
avoided, could result in serious injury or death. 

WARNING symbol on the equipment refers the user to the product 
manual for additional information. The symbol appears next to 
required information in the manual. 
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Symbol Definition 
 

 
 

 
WARNING, Risk of electrical shock: Potential shock hazard where 
HAZARDOUS LIVE voltages greater than 30 Vrms, 42.4 Vpeak, or 
60 VDC may be accessible. 

 

 
 

 
ESD HAZARD: Danger of an electro-static discharge to which 
equipment may be sensitive. Observe precautions for handling 
electrostatic sensitive devices. 

 

 
 

 
Protective Earth (PE) terminal: Provided for connection of the 
protective earth (green or green/yellow) supply system conductor. 

 

 
 

 
Functional earth terminal: Used for non-safety purposes such as 
noise immunity improvement. NOTE: This connection shall be 
bonded to Protective Earth at the source of supply in accordance 
with national local electrical code requirements. 

 

 
 

 
Earth Ground: Functional earth connection. NOTE: This 
connection shall be bonded to Protective Earth at the source of 
supply in accordance with national and local electrical code 
requirements. 

 

 
 

 
Chassis Ground: Identifies a connection to the chassis or frame of 
the equipment shall be bonded to Protective Earth at the source of 
supply in accordance with national and local electrical code 
requirements. 
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Enterprise Model Builder 
The Enterprise Model Builder (EMB) is the application used to build, edit and download 
an Enterprise Model in Experion or EBI systems.   The enterprise model provides a 
means of organizing the system around the key entities (items) in the customer’s 
enterprise, such as assets, material, activities and people.      

Using the Enterprise Model Builder you can: 

• Create and construct an asset model 

• Create and construct alarm groups 

• Load asset model and alarm group configurations to the servers. 

• Export/Import asset models and alarm group files 

• Merge multiple enterprise models into one system 

• Divide an enterprise model among multiple systems 

Before you Begin 
If you are not familiar with the Enterprise Model or the Enterprise Model Builder 
application, read the following topics that provide conceptual, planning and procedural 
information about building an enterprise model in Experion:  

• Experion Server and Client Planning Guide, Section: Assets and asset models. 
Provides concept, planning and design information for creating an enterprise model.  

• Experion Server and Client Configuration Guide, Section: Configuring the enterprise 
model– Describes the various components of the enterprise model and outlines the 
tasks necessary to build the enterprise model.  
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Terminology 
The following terms are used in this document when describing the enterprise model and 
its components that enable it: 

 
Term Definition 

Enterprise Model 
(EM) 

The collective grouping of the Enterprise model database 
(EMDB) and the EM runtime. 

EM Runtime The portion of the EMDB that is loaded to the servers, and that 
is used for determining Scope of Responsibility, Alarm 
Displays, etc. 

Enterprise Model 
Builder (EMB) 

The application used to configure the asset model, alarm 
groups and the server definitions. 

Enterprise Model 
Database (EMDB) 

The repository for the asset model, alarm groups and server 
definitions in Experion. 

System The set of servers that reside within the domain of an 
enterprise model. 

System server The server that hosts the EMDB.  
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EMB Installation 
Enterprise Model Builder is installed as part of server installation in Experion. EMB can 
be installed on a system server, or on a standalone node, such as Experion Application 
Framework (EAF) node.     

• Installation on an Experion server is mostly automatic and requires only that you 
identify the server as a system server which will host the EMDB.   

• Installation on a standalone node requires the following prerequisites:   

− . NET Framework 1.1 SP1 must be installed on the computer before installing 
EMB Server or EMB Client 

− Microsoft SQL Server must be installed on the computer before installing EMB 
Server. 

 
Step Action 

1 Log on to the computer as an administrator (e.g. Administrator). The account 
must be a member of the local Administrators group. 

2 Close all running applications. 

3 Insert the EMB Installer Software CD into the disk drive. 

4 In Windows Explorer, browse to the root folder on the CD, and then 
double-click the setup.exe file.   

Close Windows Explorer. 

5 Follow the prompts in each screen and select the appropriate options 
for installation.  

 



Enterprise Model Builder 
Using Enterprise Model Builder 

4 Experion Enterprise Model Builder User's Guide  R301.1 
 Honeywell 11/06 

 

Using Enterprise Model Builder 
This section includes links to information that you can reference for using Enterprise 
Model Builder.  Click on a topic: 

 
Topic 

EMB guidelines 

Guidelines when using Enterprise Model Builder 

Naming Conventions in the Enterprise Model 

Building the enterprise model 

Accessing Enterprise Model Builder 

Set System Name 

Define Servers 

Load System Model 

Create and configure assets 

Load Asset model 

Create and Configure an Alarm Group 

Load Alarm Groups 

Error Messages and Troubleshooting 

EMDB administration 

EMB Installation  

Database Administration 

Backup and Restore EMDB 

Migrating the EMDB 

Merging Enterprise models  (See Software Change Notice document) 

Splitting the Enterprise models  (See Software Change Notice document) 

Generate Reports 

Change permissions 
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Naming conventions in the Enterprise Model  
All items in the Enterprise Model (systems, servers, assets and points) have a tag name 
which is a unique name used by the system to identify that item.  In addition to the tag 
name, items also have an Item Name and an Enterprise Model Name (also referred to as a 
Full Item Name) which provides a more structured way of identifying items. 

Item Name 
Item Name is a property that is given to all tagged objects in the system.  It is a means to 
provide a more descriptive name to an item, rather than using just a tag name for 
identifying an item.  Item name does not have to be unique within a system, but it must 
be unique among the children of the same containment parent.  In Enterprise Model 
Builder, when you create an asset or alarm group, a default item name is given to that 
item.  You can then enter another name to easily identify the item within the enterprise 
model.   

Enterprise Model name, (Full Item Name) 
The enterprise model name is comprised of a set of individual names, one for each 
individual item. In many cases the structure of the name used to name items in a model is 
defined by the structure of the model itself, as is the case for the asset model. For 
comparison, the enterprise model name is similar to the pathnaming convention that is 
used for defining files within folders and directories in a Windows environment. 

In Enterprise Model Builder the full item name has the following general form: 

[/SystemName][/Model]/TopLevelItem/Item/.../Item 

The SystemName refers to the name of the DSA system which the particular enterprise 
model includes.  If the system name is not specified, then the local system is assumed. If 
the model name is not specified, then the asset model is assumed. 

As an example, the following name refers to an agitator asset in the 1st precipitator on 
Train 1 in precipitation: 

/Assets/Precipitation/Train1/Precipitator1/Agitator 

Item names must be unique amongst the children of a particular asset. 

Alarm groups can be referenced similarly as follows: 

/AlarmGroups/AlarmGroup1 
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Tag name 
All enterprise model items have a unique tag name (point name) that identifies the item 
throughout the system. There are cases in which it is more convenient to identify a point 
or item directly by its tag name.  

Points and alarm groups also can be given an enterprise model name when associated 
with assets in the asset model. This allows the points/alarm groups to be identified by 
names that are more meaningful to users of the system than only tag names.  The system 
allows either tag names or full item names to be used to identify points and items. 

The name for point tags spans the entire DSA system and the system assumes that point 
tag names are unique throughout the system. However, there are cases where point tag 
names may not be unique. For example, when two LCN systems on separate Experion 
servers are integrated into a DSA system, the LCN systems may contain duplicate tag 
names. A similar situation can occur when two separate existing Experion servers are 
first integrated in a DSA system. 

Support for duplicate tag names 

In order to discuss duplicate tag name support, we need to distinguish between two 
different types of points. “Server-owned points” are points that are “owned” by a 
particular server. Examples are analog, status, and CDA points. “System-owned points” 
are points that are “owned” by the system as a whole (which may span several servers). 
Examples include asset and alarm group points. 

Duplicate tag names for “server-owned points” are supported so long as they exist on 
separate servers. Duplicate tag names for “system-owned points” are supported so long 
as they exist in separate systems. To distinguish between two “server-owned points” with 
duplicate tag names, the tag name must be pre-pended with the server alias. To 
distinguish between two “system-owned points” with duplicate tag names, the tag name 
must be pre-pended with the system name.  

To reduce the possibility of clashes with enterprise model names, the colon character (‘:’) 
is used when pre-pending the server or system name to the tag name. Note that a 
“system-owned point” can never have the same tag name as a “server-owned point”. 

Example of a tag name for a “server-owned point” 

 “AS01HSCWENDY:FIC123” 

Example of a tag name for a “system-owned point” 

 “Mighty River Hydro:TANK01” 
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For “server-owned points” where the server alias is not specified the local server is 
assumed.  Similarly, for “system-owned points” where the system name is not specified 
the local system is assumed. 

As an option you can set a server wide option to indicate that duplicate tag names are not 
allowed. If this option is selected, then tag name insertion fails whenever a duplicate is 
detected and an alarm is raised (which is consistent with current system behavior). If you 
enable this option but duplicate tags already exist, then an error message is displayed 
informing you that you must first remove all of the duplicates from the system.  This 
option is enabled by default. 

Duplicate tag name enforcement 
The Enterprise Model Builder is responsible for ensuring that the tag names of all assets 
and alarm groups in an enterprise model are unique. When an alarm group is created, it 
may reference one or more points which have duplicate tag names.  In order to resolve 
this ambiguity, the EMB stores these referenced tag names pre-pended with either the 
system name or the server name as appropriate. If the Point Browser is used to pick the 
tag names that belong to an alarm group, then it will return the pre-pended tag name 
when appropriate. If you type in a tag name without pre-pending it and there happens to 
be duplicates, then an error is raised by the Experion server when the download is 
attempted. 
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Guidelines when using Enterprise Model Builder 
In General 

• Up to 10 servers can be added for access to EMB in a system.   

• The Enterprise Model Database, EMDB (which is separate from other engineering 
and system databases), resides on the system server.   

• Asset models and alarm groups can be created and configured off-line much the 
same way as control strategies can be configured in Control Builder.  Later, the asset 
model files can be loaded to the servers. 

Asset model / Alarm group restrictions 
• An asset model can contain up to 4,000 individual assets.   

• Since the asset model is a hierarchical arrangement of assets, a model can have up to 
10 levels defined.  For example, an asset can have children associated with it nine 
levels deep.   Although it is practical to have no more than five levels.  

• Up to 1,000 assets can be designated as assignable within a system model.   

• Up to 5000 alarm groups can be defined within a system model. 

• The hierarchy in an alarm group can be up to 5 levels deep. 

Client node restrictions 
• EMB can be installed on client nodes so that up to 4 users can access and use EMB.   

• Each client node may run one asset configuration and one alarm group configuration 
simultaneously from the same client node. 

• Up to a total of 6 instances of Control Builder and EMB can be running on a 
workstation at once.  For example, you may have 3 instances of Control Builder 
open and 3 instances of EMB on the same client node.  Or any combination of the 
two applications that total 6.  

• Up to 4 alarm group configurations may be run from different client nodes 
simultaneously. 
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Accessing Enterprise Model Builder 
Access to Enterprise Model Builder is through the Configuration Studio.  Some of the 
higher level tasks associated with the enterprise model are performed within 
Configuration Studio.   

For example, if you want to:  

• Set or Rename the System Name 

• Add/Remove Servers from the system 

• Edit Server parameters 

• Export and import server definitions 

• Load System Model Configuration to servers 

• Administer the system database, (Enterprise Model Database, EMDB) 

• Create a Network tree  

You can initiate these tasks directly from Configuration Studio in the Configuration 
Explorer tab as shown in Figure 1.  
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Figure 1 Configuration Explorer system tree and task list 
 

 
 

The Network tree 
Starting with Experion Release 300.1 you can configure a network tree that enables you 
to view nodes in the system network, such as computers, groups of computers 
(workgroups, and domains), switches and routers, and the devices which comprise FTE 
communities.   
The network tree is shown in the Configruation Explorer window under ‘Network.’ See 
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Figure 1.  The network tree (model) resides in the Enterprise Model Database (EMDB) 
and is considered part of the system Enterprise Model.  The status and health of these 
nodes in the network tree can be viewed on the System Status display.   

Enterprise Model Builder is not used to configure the network tree.  See the topic 
‘Configuring the Network tree’ in the Server and Client Configuration Guide for the 
details in creating and managing the network tree.   

Set system name (Rename System) 
Description 

When Enterprise Model Builder is installed on the server, a default name is given to the 
system name which then can be changed.  The system name must be unique as it is used 
by the cluster or all of the servers that are a part of the enterprise model.   

The system name, which is prefixed to the asset or point name, can be used to distinguish 
assets/points in one cluster (or system) from the assets/points in another cluster (or 
system).    

Prerequisites 
• At least one user has been defined on the server. 

• You have launched Configuration Studio and connected to a system with a logon 
security level of Engineer or greater.  

Considerations 

Note that when you select ‘Rename this system,’ a lock occurs that prohibits any changes 
to the system configuration by any other users.  Once the new name is validated, the lock 
is released. 

To change the system name: 
 

Step Action 

1 From Configuration Explorer tab, select the System Task: 

 Rename this system 

The SYSTEM:ROOT Block parameters form is displayed. 

2 Enter the new system name (Tag Name), no more than 40 characters in 
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Step Action 
length.   

Enter an Item Name (optional). 

3  Press Enter or OK 

4 Select the task: 

 Load System Configuration to servers… to load the system 
configuration to all servers so that the new system name is distributed to all 
servers in the system.  See Load System Model for a procedure and more 
information.  

 

Add servers 
Servers within the system are considered assets and are part of the system model.  
Servers are defined and added as part of the system model in Configuration Studio.   

Prerequisites 

• At least one user has been defined on the server. 

• You have launched Configuration Studio and connected to a system with a logon 
security level of Engineer or greater.  

Considerations 

When adding a server, you can choose to import into the Enterprise Model Database any 
areas, assets and alarm groups defined on that server.  Messages will prompt you on your 
choices.  

To define system servers in the enterprise model:  
 

Step Action 

1 In the Configuration Explorer tab, select the Server Task  

 Add a server to this system.  

The SYSTEM:SERVER Block parameters form is displayed. 
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Step Action 

 
 

2 The form contains a default tag name in the Alias field.  Enter a unique Tag 
Name.  

3 Enter a text description of the server in the Description field.  

4 Enter an abbreviated name for the server in the Abbreviation field. 

5 Server External To System? If so, check the box.     

Note that adding a check to this box will gray out the Description and 
Abbreviation fields of the parameters form.   

6 Add a check to designate the server as Non-Publishing.   

For example, an E-server. 
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Step Action 

7 Enter the name of the server Node to where the system configuration will be 
loaded.  (It can be the same as the server tag name.)  

8 Select the Network Type from the drop down combo box in which the server 
is connected.  (SINGLE/FTE, or DUAL) 

9 Is the server redundant?  If so, check the Redundant? box 

10 Click on the ‘Identification’ tab to display a second page of the property 
form.  

 There are four Comment fields in which you can enter pertinent information 
about the server.   

11 Click ‘OK’  

12 A Server login dialog screen appears.  Enter a valid username and 
Password.  Choose <None> as your Domain.  Click ‘OK.’ 

 A Migration of Asset Model/Alarm Groups dialog appears prompting you to 
choose whether to import the existing asset model/alarm groups on the newly 
created server into the Enterprise Model Database.   

 You have the option to Overwrite an item (object) in the database if a 
duplicate entity is found in the database being imported.  Uncheck the box 
if you want to be prompted when a duplicate is found.   

See Migration of Assets and Alarm Groups from Servers to EMDB for more 
information.   
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Step Action 

 
 

 
Note that if you choose ‘Skip,’ any existing areas, asset model and alarm 
groups on the server will be overwritten when a model is loaded to that 
server.   

13 If you choose ‘Continue,’ the areas, asset model and alarm groups will be 
imported into the EMDB.   

 

 
 

 Once completed, the newly added server now appears in the System Model 
tree in Configuration Explorer. 

If migration of an asset model or alarm groups fails, the server is not added to 
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Step Action 
the system.   

14 Repeat steps 1 through 13 in this procedure for each server to be defined in 
the system model. 

  
Note that after a server is added to the system, an icon respresenting the server appears in 
the Configuration Explorer tree view.  Under the server icon is a compliment of 
categories (Stations and Consoles, Printers, Control Strategy, etc.).  Selecting any of 
these categories displays a list of related tasks at the right of the window.  Choosing a 
task will an application window or a dialog which enables you perform that task.  See the 
topic “Configuration procedures” in the Server and Client Configuration Guidefor more 
information.     

 

Load system configuration 
The system configuration load task downloads system configuration to all of the 
configured servers in the system. System configuration in EMDB consists of the 
following: 

• System name 

• All configured servers’ definitions 

Prerequisites 

• You have launched Configuration Studio and connected to a system with a logon 
security level of Engineer or greater.  

• Mngr passwords should be the same across all servers on a system.   

Considerations 

A system configuration load is performed during initial server configuration and anytime 
that system name or any server configuration has been changed.  Note that the system 
configuration is also loaded to the servers as part of loading Asset model and Alarm 
Groups.  

Load System Configuration is a task performed in the Configuration Explorer. 

Note that when you click ‘OK,’ a lock occurs on all items of the system, the servers 
selected for load and all configured servers.  If the system or any of the servers selected 
to be loaded are already locked, an error is reported and the load operation is aborted.  If 
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any of the configured servers are already locked, an error is reported and the load 
operation is aborted.  For example, another user may be using the server.  See Server 
Load Status and Error Messages for more details.  

To load a system configuration to selected servers: 
 

Step Action 

1 From the Configuration Explorer tab, select Server Task 

 Load system configuration to servers 

 The following dialog appears which allows you to select servers to be loaded.  

 
 

 
 

 See Load system configuration dialog features for an explanation of the 
information presented in the Load dialog.   

2 Select the servers that you want to download with the system configuration 
by adding a check mark in the Load Column next to the Server Name. 

3 Uncheck any servers that you do not want to load at this time.   

 Note:  If no servers are selected for load, then the ‘OK’ button is disabled. 

4 Click the ‘OK’ button to begin the system configuration load operation on all 
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Step Action 
selected servers. 

 The Loading System Configuration dialog appears showing the name of all 
servers selected for load, the load status and a detail description for each 
server.  A progress bar is shown for the duration of the load operation.  

 

 
 

 The load operation validates all server names for all the configured servers in 
the system, on the server(s) selected for load. 

 If the load operation is successful without detection of any errors or warnings, 
a Load Status of “Complete” appears. 

5 If any errors occur during the load operation, you should correct the fault and 
then perform the load procedure again.  See Load Errors for more 
information. 

 



Accessing Enterprise Model Builder 
Load system configuration 

R301.1 Experion Enterprise Model Builder User's Guide 19 
11/06 Honeywell 

Load system configuration dialog features 
 

The following fields appear in the Load dialog and the Load System Configuration 
dialog: 

 
Feature Description 

Load Check boxes allow you select to which servers you want 
to load.  By default, all listed servers are selected.   

Server Name A list of all configured servers in the cluster or system.  
Remote servers are not shown.  If any of the servers 
selected for load are redundant, the EMB loads to the 
primary server, then the changes are synchronized to the 
secondary server.    

Date Loaded To Server Indicates the date and time this model was last loaded to 
the server.  

Force Load Add a check to this box if you want to override the existing 
system and repository name in the selected servers. 

Help The Help button calls to open Knowledge Builder and 
display information about loading system configuration. 

Details/Errors Show the details relating to the Load Status. If errors 
occur, a message is displayed.  See Error Messages for 
more details. 
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Create and configure assets 
The first step in constructing an asset model is creating and configuring assets which are 
the items (entities) that make up the asset model.    

Prerequisites 

• You have launched Configuration Studio and connected to a system with a logon 
security level of Engineer or greater.  

• You have already created a system model and configured servers in Configuration 
Studio.  

Considerations 

If you have migrated an existing system that contained areas, then these areas are 
converted to top level assets and appear in the asset model tree.  See Migration for more 
details.   

Note that when a new asset is created, it will appear as a child of the asset which was 
highlighted in the tree view.  You can then click, drag and drop the asset to the 
appropriate place in the model.   

To create and configure new assets in the asset model:  
 

Step Action 

1 In the Configuration Explorer tab select the top level asset in the System tree.  

Select the System Task 

 Configure Assets for this system.   

 The Enterprise Model Builder – Asset window appears as a separate window.  
The left side of the window shows a tree view of the asset model structure.   

2 If a tree view window is not visible in the Asset window, click on the ‘Open 

Tree’ icon  on the toolbar to open the asset model.   

The following figure shows an asset model tree view with several assets 
already defined. 
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Step Action 

 
 

3 Choose File > New ASSET… An ASSET Block Parameters form is 
displayed. 
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Step Action 

 
 

4 The form contains a default tag name.  Enter a unique Tag Name. 

5 The form contains a default Item Name.  You can enter another name if you 
want. 

6 Enter a text description of the asset in the Description field.  

7 Enter the name of the Point Detail Page and Associated Display in the 
appropriate fields. 

8 Check the box ‘Directly Assignable (for scope of responsibility and alarm 
enable/disable)’ If you want the asset to be assignable to an operator, 
Station or alarm group.    

For more information about assignable assets, see About assignable assets, 
or Planning your Asset Model for additional planning information. 
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Step Action 

 Note that the icons which represent assets designated as assignable are 
brighter in color than the icons of unassigned assets.  See the figure in step 2 
above.  

9 Click on the ‘Identification’ tab to display a second page of the property 
form.  

 There are four Comment fields in which you can enter additional information 
about the server.   

10 Click ‘OK’ to create the asset which now appears in the Asset Model tree.   

 
TIP 

You can arrange assets within the asset model tree view according to your 
system specification simply by the click, drag and drop method. 

11 Repeat steps 3 through 10 in the procedure for each asset to be defined in 
the asset model.   

12 After configuring assets and building the asset model, perform a Load asset 
model and alarm groups to the servers in the system.   

 

Create and configure alarm groups 
Alarm groups provide a means to monitor a group of assets and or data points that are 
otherwise unrelated to one another in the asset model.  Alarm groups are built using the 
parameters forms, and assets are associated with alarm groups by entering the asset tag 
name into the parameters form for the alarm group.   

Note that alarm groups are referenced with other alarm groups through a containment 
relationship, where one alarm group is contained by another; (much like assets in the 
asset model).  A set of alarm groups defined in a system effectively form an alarm group 
model, which is separate from the asset model. 

Alarm groups are created and configured in the same way as assets.  Assignable assets 
and data points then can be associated with the alarm group.     

Prerequisites 

• You have launched Configuration Studio and connected to a system with a logon 
security level of Engineer or greater.  
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• You have created an asset model and configured assets that are assignable using 
EMB. 

• You have built and configured points, and associated them with assets using Quick 
Builder or Control Builder.  

• Points and assets should be loaded.   

Considerations 

If you have migrated an existing system that contained alarm groups, then the alarm 
groups are added to the EMDB.  See Migration for more details.   

Note that when a new alarm group is created, it will appear as a child of the alarm group 
which was highlighted in the tree view.  You can then click and drag the asset to the 
approporate place in the model.   

To create and configure alarm groups for the system:  
 

Step Action 

1 In the Configuration Studio Explorer tab select the top level asset in the 
System tree.   

Select the System Task 

 Configure Alarm Groups for this system.   

 The Enterprise Model Builder – Alarm Groups window appears as a separate 
window.  The left side of the window shows a tree view of the alarm group 
model structure.   

2 If a tree view window is not visible in the Alarm Group window, click on the 

‘Open Tree’ icon  on the toolbar to open the the Alarm Group model.   

3 Choose File > New ALARMGROUP…, An Alarm Group Parameters form is 
displayed. 

 The following figure shows an alarm group parameters form with several 
fields already defined. 
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Step Action 

 
 

4 The form contains a default tag name.  Enter a unique Tag Name. 

5 The form contains a default Item Name.  You can enter another name if you 
want. 

6 Enter a text description of the asset in the Description field.  

7 Enter the tag name of the asset you want to associate with this alarm group 
in the Associated Asset field. 

8 Enter the name of the Point Detail Page and Associated Display in the 
appropriate fields. 

9 Enter the number of items, (assets and data points) that you want to be in this 
alarm group.  Limit of 20 items. 
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Step Action 

10 Enter the tag names of the assets and data points that you want to include in 
this alarm group.   

11 Click on the ‘Identification’ tab to display a second page of the property 
form.  

 There are four Comment fields in which you can enter additional information 
about the server.   

12 Click ‘OK’ to create the alarm group which now appears in the Alarm Group 
Model tree.   

 
TIP 

You can arrange alarm groups in the tree view according to your system 
specification simply by the click and drag method. 

13 Repeat steps 3 through 12 in the procedure for each alarm group to be 
defined in the alarm group model.   

14 After configuring the alarm groups and building the alarm group model, 
perform a Load asset model and alarm groups to the servers in the system.   

 

Alarm Group icons 

Alarm groups are represented in the tree view by the following icons: 
 

Description Icon 

Alarm Groups  

Alarm Groups with multiple parents 
 

Load and change status 
Symbols, which are displayed next to asset or alarm group icons in the tree view, indicate 
the load and change status of that item.  The ‘needs load’ symbol appears when an asset 
has been created, but has not been loaded to a server as part of the model.  The ‘change’ 
symbol appears when an existing asset, model or alarm group has been changed since the 
last time the model has been loaded to server.   
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Load status 
Figure 2 shows the ‘needs load’ symbol (double down arrows) next to each item of the 
tree that needs to be loaded, including the root node. Once the model is loaded to at least 
one server, the ‘needs load’ symbol disappears. 

 

 
 

Figure 2  Symbol indicating the item should be loaded to a server.  

Change status 

If a new item is added to a model or if a change is made to an existing item, the ‘change’ 
symbol will appear next to the root node of the model indicating that model structure has 
changed.  See Figure 3.  Note that the ‘needs load’ symbol appears next to the new item 
(New Asset) or changed item in the model.  Once the model is loaded to at least one 
server, the ‘change’ and needs load’ symbols are removed from the model tree. 

 



Accessing Enterprise Model Builder 
Load asset model and alarm groups (Load Entire Model) 

28 Experion Enterprise Model Builder User's Guide  R301.1 
 Honeywell 11/06 

 
 

Figure 3  Asset model showing the ‘change’ symbol next to the root node 
  

Load asset model and alarm groups (Load Entire Model) 
The asset model and/or alarm groups can be loaded to servers that are configured as part 
of the Enterprise Model.   

The procedure is the same when loading either the asset model or alarm groups.   

Prerequisites 

• You have launched Configuration Studio and connected to a system with a logon 
security level of Engineer or greater.  

• A system model has been created consisting of at least one server.  

• You have an Enterprise Model Builder window open with either an asset model tree 
or alarm group tree displayed.  

• An asset model or alarm groups have been created in Enterprise Model Builder for 
the system.  
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Considerations 

The asset model and alarm groups can be loaded to the following server types: 

• Experion Server 

• Plant Reference Model (PRM) Server  

This operation loads the entire asset model or alarm groups to the selected servers. The 
entire model includes the system configuration and all defined items in the model, which 
includes the top-level asset or alarm group and all assets or alarm groups associated with 
that item.  Individual assets cannot be loaded, assets and alarms are loaded as a model. 

 

 
ATTENTION 

During the load operation, assets and points may temporarily belong to 
unassigned items in the Alarm Summary display.  The tree view on the left of 
the display may show an incomplete model.  Additionally, alarms may 
temporarily be raised against assets and points in the model showing a blank 
location field.  These conditions should clear once the download is 
completed. 

 
Note that when you click OK, a lock occurs on all items of the Asset model and/or Alarm 
group and all configured servers selected for load.  If the asset model or alarm group to 
be loaded is already locked, an error is reported and the load operation is aborted.  If any 
of the configured servers are already locked an error is reported and the load operation is 
aborted.  See Load Errors. 

To load the asset model or alarm groups to selected servers:  
 

Step Action 

1 Select the menu and choose Tools > Load Entire Model… or Click on the 

Load icon  on the tool bar. 

Also, you can select any asset or alarm group in the tree and right click. 

Choose Load Entire Model… 

 The following Load dialog appears: 
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Step Action 

 
 
See Load Dialog features for an explanation of the information presented in the Load 
dialog.   

2 Select the servers that you want to download with the asset model or alarm 
group by adding a check mark in the Load Column next to the Server Name. 

3 Uncheck any servers that you do not want to load at this time.   

 Note:  If no servers are selected for load, then the ‘OK’ button is disabled. 

4 Choose whether or not to Force Load the servers.  This check box allows the 
load to proceed even if the system name or repository name has been 
changed.  

5 Click the ‘OK’ button to begin the asset model load operation concurrently on 
all selected servers.   

 The Loading Asset (or Alarm Group) dialog appears showing the name of the 
top-level asset (or alarm group) being loaded.  A progress bar is shown for 
the duration of the load operation. The name of all servers selected for load, 
the load status and a detail description for each server also are shown.  See 
figure.   

 



Accessing Enterprise Model Builder 
Load asset model and alarm groups (Load Entire Model) 

R301.1 Experion Enterprise Model Builder User's Guide 31 
11/06 Honeywell 

Step Action 

 
 

 During the load operation, the EMB validates the server names of all the 
configured servers in the system as well as the point and full item names of 
the asset model or alarm groups.   

6 If the load operation is successful without detection of any errors or warnings, 
a Load Status of “Complete” appears.   

If any errors occur during the load operation, you should correct the fault and 
then perform the load procedure again.  See Load Errors for more 
information. 

 

Load dialog features 

The following information is given in the Load dialog: 
Note that the Load Dialog is the same when loading alarm groups to server 

 
Feature Description 

Asset to load: The name of the asset or alarm group selected for loading. 
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Feature Description 

Date Last Changed: The date that the asset model was last revised or changed. 

Load Check boxes allow you select to which servers you want to 
load the asset model.   

By default, any servers that have not been loaded since the 
asset model has been changed (Date Last Changed) are 
selected for load.   

Server Name A list of all the configured servers in the cluster or system.  
Remote servers are not shown.  If any of the servers 
selected for load are redundant, the EMB loads to the 
primary server, then the changes are synchronized to the 
secondary server.    

Date loaded to Server The date and time that selected asset model was loaded to 
the server.  If this is the first time that the asset model is 
being loaded to the server, no date is shown.   

Force Load (Override 
existing system and 
repository name) 

A check in this box allows the load to proceed even if the 
system name or repository name has been changed.   

Help The Help button calls to open Knowledge Builder and 
display information about loading an asset model or alarm 
group. 

 

Open object (Item) 
In systems that contain a large number of assets, it can be difficult to find a particular 
asset in the model tree.  This feature allows you to find an asset (item) in the Enterprise 
Model quickly and open the properties form for the asset.  This procedure also can be 
used to open alarm group items.    

Prerequisites 

• You have launched Configuration Studio and connected to a system with a logon 
security level of Engineer or greater.  

• A system model has been created consisting of at least one server.  

• You have an Enterprise Model Builder window open with either an asset model tree 
or alarm group tree displayed.  
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• An asset model or alarm groups have been created in Enterprise Model Builder for 
the system.  

Considerations 

• In the Open Object dialog ‘Item’ is the default selection so you can search by item 
name. To search by tag name, selecte the ‘Tag’ radio button. 

• If multiple items in the model contain the same item name (for example, Boiler 1), 
enter the Full Item Name in the edit box (Assets/PlantA/Boiler 1).  If you use just the 
item name, the EMB will open the first occurrence of the item in the tree with the 
same item name.   

To open the properties form of an asset: 
 

Step Action 

1 Select File> Open  

2 The Open Object from Asset dialog appears: 

 
 

 
 

3 Enter the name of the Asset in the edit box.   

4 Choose whether the name is the Item name or the Tag name by clicking the 
appropriate radio button. 

Note: When searching by item name, multiple items may have the same item 
name so enter the full item name in the edit box.  

5 Click Open. 

6 • If the Asset exists in the tree of the active window,  

− The Properties form of the asset is opened and the active window will 
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Step Action 
expand the model tree to show the highlighted asset (as shown in 
Figure 4). 

• If the asset does not exist in the active window, or if the asset has not been 
loaded to the server. 

− An error message is displayed.   See Error messages. 
  

 
 

Figure 4  Tree view of the asset model 
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Error messages 

Any of the following error messages may appear when attempting to open an item.  The 
messages are listed in the following table with the cause.   

 
Message Text Cause 

The item you wish to open is in another 
model tree. Please select the correct 
tree. 

You have selected a tree in which the 
item does not exist.   

The item you wish to open does not exist 
in the current view (i.e., assignment or 
containment). Please change the view 
and try again. 

You have selected the wrong view (for 
example, asset vs. alarm group).  

The name you entered does not exist. 
Please make sure the name is spelled 
correctly. 

You have entered the name of an item 
that does not exist in the database.  

Please enter the name of an item to 
open. 

Nothing was entered in the edit window. 
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Database Administration 
Administration of the Enterprise Model Database (EMDB) consists of basic functions 
that are used to edit, delete, copy, move, export and import the parameters of items 
defined in the EMDB, such as servers, assets or alarm groups.  Other higher level 
administration functions, which include use of the dbadmin utility to backup and restore 
the database, are essential in maintaining the integrity of the EMDB.   

 

 
TIP 

Perform a Load Entire Model (Load Asset model and Alarm Groups) to 
update all servers in the system after you have made any changes to the 
Enterprise Model.   

 

EMDB Backup and Restore 
The system utility DBADMIN is used to perform database backup and restore functions 
for the EMDB.  Note that in the case of redundant EMDB servers, backup and restore 
functions can be performed using the secondary server if necessary.   

Prerequisites 

• You have launched Configuration Studio and connected to a system with a logon 
security level of Engineer or greater.  

• For redundant servers, ensure that primary and secondary EMDB servers are 
synchronized and replication is enabled. 

To backup the EMDB: 
 

Step Action 

1 From the Configuration Explorer tab, choose the System task Administer the 
system database. 

 The DBADMIN utility will open in a separate window. 

2 Click the plus sign for DbAdmin folder icon and then the plus sign next to the 
Server folder icon to expand the tree structure. 

3 Open the EMDB Admin Tasks folder 

4 Click on the Backup Database icon.  The Backup To dialog box appears. 
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Step Action 

5 Click the down arrow in the Save in field and select the desired directory from 
the drop down menu.  A common directory location is c:\Program 
Files\honeywell\Experion PKS\Engineering Tools\system\ER 

6 Key in the desired file name in the File name field.  
For example, >ps_emdb_1.bak<. 

 A backup copy of the current database is created as a ".bak" file under the 
specified name and in the selected directory location on a local drive 

7 Wait for the message prompt to announce the successful completion of the 
backup.  Click OK. 

8 Click Console > Exit to close dbadmin window and return to normal 
operation.  

 

To restore a user selected backup EMDB (.bak file): 
 

Step Action 

1 From the Configuration Explorer tab, choose the System task Administer the 
system database. 

 The DBADMIN utility will open in a separate window. 

2 Click the plus sign for DbAdmin folder icon and then the plus sign next to the 
Server folder icon to expand the tree structure. 

3 Open the EMDB Admin Tasks folder 

4 Click on the Restore Database icon. 

5 A prompt asks if replication is disabled and if you want to continue.   

6 Click OK.  The Restore From dialog box appears. 

7 Click the down arrow in the Look in field and select the desired directory from 
the drop down menu.  A common directory location is c:\Program 
Files\honeywell\Experion PKS\Engineering Tools\system\ER 

8 Select the desired backup database (*.bak) in the list box so it appears in the 
File name field. 

9 Wait for the message prompt to announce the successful completion of the 
restore.  Click OK. 

10 Click Console > Exit to close dbadmin window and return to normal 
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Step Action 
operation. 

 
Additional information on using the DBADMIN utility is found in the C200 Hardware 
Troubleshooting and Maintenance Guide  in Knowledge Builder.  

Edit, Copy, Delete, Export/Import 
These functions are basic to configuring and changing the parameters of items, asset 
models and alarm groups in the enterprise model.  These include Edit, Delete, Copy, 
Move, Export and Import functions.  Some of these functions are found under the Edit 
menu, or by right clicking on an asset or alarm group in the model. 

Prerequisites 

• You have launched Configuration Studio and connected to a system with a logon 
security level of Engineer or greater.  

• An asset model and alarm groups has been created in Enterprise Model Builder for 
the system.  

Edit 
The Edit function allows you to change the names and configuration parameters 
(properties) of assets and alarm groups.   

Considerations 

Any configuration parameters or names that you change during the edit session will 
appear as underlined so that you can see what changes were made. 

Note that when you select ‘Edit,’ a lock occurs that prohibits any changes to the selected 
asset or alarm group by any other users.  Once the form is closed, the lock is released.  If 
the asset or alarm group is already locked, then a popup message appears to indicate that 
another user is accessing the form.  You then have the option to open the form as read 
only. 

To edit the properties of assets and alarm groups: 
 

Step Action 

1 Select an asset or alarm group to edit. 
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Step Action 

2 Then either: 

• Use the menu and choose Edit-> Properties …, or 

• Right mouse menu and choose Properties …, or 

• Double click the Configuration Properties icon on the toolbar 

3 The configuration parameters form will open for the asset or alarm group. 

4 Make changes to any parameters which are available in the form.  

 
TIP 

To access a help topic associated with a parameter, select that parameter 
and then press F1. 

5  Click OK to add the changes to the EMDB.  Clicking Cancel will close the 
form without adding the changes to the database. 

 

Rename 
You can change the name of an asset or point name of alarm group without editing 
configuration parameters.  The Rename function is available when configuring the asset 
model or alarm groups.   

Considerations 
 

 
ATTENTION 

If you change the Tag name of an asset or the Point name of an alarm group, 
(either through the parameters form or by using the Rename function), a 
message will appear warning you of the impact of the name change, as 
shown in the procedure. 

 
Note that when you select ‘Rename,’ a lock occurs that prohibits any changes to the 
selected asset or alarm group by any other users.  Once the rename is completed, the lock 
is released.  If the asset or alarm group is already locked, then a popup message appears 
to indicate that another user is accessing the form. 
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To change the name of a selected item: 
 

Step Action 

1 Select one item from the tree view. 

2 Use the menu and choose Edit->Rename ,or  

Press F2 button, or right mouse click menu and choose Rename. 

3 An edit box in the tree pane appears and allows you to enter a different 
name. 

4 Press Enter, or mouse click away from the edit box to complete the change.  

If you rename a Tag name of an asset, you will be prompted with the following screen: 
 

 
Click OK if you want to update the tag name, or Cancel to restore the previous tag 
name. 

 

Copy 
The Copy function allows you to select one or more items (assets and/or alarm groups) 
and then copy them to another location in the enterprise model.  Note that if a selected 
asset contains assets which are children of the selected asset, the children are also copied.   

You also can select more than one item to copy at one time, which may result in multiple 
copys of selected items.  For example, consider the asset tree below. 
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You select the Asset A1_106 and Asset A_108 to copy.  When you perform the copy 
operation, the Asset A1_106 and its children (Assets A_107, A_108, and A_109), and 
Asset A_108 and its child (A_109) are copied.   

Considerations 

Note that when you select ‘Copy,’ a lock occurs that prohibits any other users from 
making changes to the selected items.  Once the items are copied, the lock is released.  
Only items that can be locked are available to be copied.  If any of the items are already 
locked, an error is reported that the item could not be copied.  You must remove the lock 
to perform the copy operation. 

To copy selected items in an asset model or alarm group: 
 

Step Action 

1 Select one or more assets or alarm groups to copy. 

2 Then either: 

• Use the menu and choose Edit->Copy…, or  

• Right mouse menu and choose Copy…, or  

• Drag the selected item(s) onto the target for the copy (with the Ctrl key 
pressed) and then drop it into position on the model in the tree pane. 
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Step Action 

3 The Name New Function Block(s) dialog appears. 
 

 
 
The dialog shows a list of items to be copied, which includes all children of 
the copied items (and their children).   

You can also search to find item names and then choose to replace them 
with other names.  A Replace dialog appears when you click on the 
‘Find/Replace…’ button. 

Item Names 

The system generates new names for the copied items.  You can either 
change the names of the copied items in the Destination column or accept 
the default names.  

The Destination name will be the same as the source name, as long as the 
item name does not conflict with any names of the same parent. 

4 Press the Finish button in the dialog to complete the copy operation. 

5 The copy operation duplicates the selected items along with the associated 
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Step Action 
children.  The Destination of the copied item(s) will be under the top level 
item if no Destination has been entered in the dialog. 

 

 
 
Note that you can click, drag and drop the assets or alarm groups to the 
desired location in the tree.   

 

Delete 
You can delete selected assets from the asset model and alarm groups from the alarms 
tree.   

Considerations 

Note that when you select ‘Delete,’ a lock occurs that prohibits any other users from 
making changes to the selected items.  Once the items are deleted, the lock is released.  If 
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any of the items are already locked, then a popup message appears to indicate that 
another user is accessing the item and the delete function will be cancelled.  You must 
remove the lock to perform the delete operation. 

To delete selected items from the enterprise model: 
 

Step Action 

1 Select one or more assets or alarm groups. 

2 Then either: 

• Use the menu and choose Edit->Delete…, or  

• Right mouse click menu and choose Delete…, or   

• You can also click the Delete icon on the toolbar, or 

•  Just press the Delete key. 

 The Delete Selected Object(s) dialog appears. 
 

 
 
The dialog shows a list of all items selected for deletion.   

If any of the selected items have children, a message will indicate that 
children of selected items will be deleted as well. 

3 The selected items and any children of the selected items will be deleted.  If a 
child of a selected item has other parents that are not selected for deletion, 
then the child will not be deleted. 
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Move 
You can move one or more items (assets and/or alarm groups) and their associated 
children from one hierarchy parent to another in the enterprise model.   

Considerations 

Note that when you select ‘Move,’ it locks both the source and target items of the move 
operation.  The lock is released when the operation is complete.  If any of the assets are 
already locked, then an error is indicated and the operation is canceled.  You must 
remove the lock to perform the move operation. 

To move selected items in an enterprise model: 
 

Step Action 

1 Select one or more items that you want to move. 

2 Then click and drag the items onto another item. 

If the moved item has another parent, the relation to the other parent is not 
affected.  The move operation will maintain the child relationships of the 
moved items. 

 
TIP 

Open a second tree view to make it easier to move items, especially when 
the tree view becomes large. You can click, drag and drop items from one 
tree view to the new location in the second tree.   

3 Note that if an item is contained by multiple parents (alarm groups support 
this also), you can move an item to a new parent, while keeping the parent 
relationship with the current parent.   

To do this, click, drag and drop the item while holding down the Ctrl and Shift 
keys until the item is dropped. 

 

Export/Import 
The export/import function allows you transfer data between different instances of the 
EMDB.  You can choose to export/import the entire asset model or alarm group, or 
segments of the model to another location in the EMDB or to an external node.  For 
example, you may want to export the model, or certain segments of the model so that you 
can reuse it in (import it to) another location.  You may want to export and save the 
model to use it as a backup. The data is exported and/or imported using XML.   
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Export 
The Export function is available when configuring the asset model or alarm groups.  
When you choose export, the selected data is saved as an xml file  

Considerations 

When ‘Export’ is selected, a lock occurs that prohibits any other users from making 
changes to the selected items.  The lock is released once the export is complete.  If any 
items are not available to be locked, an error is reported and the operation is canceled. 

To export selected items and save them to a file: 
 

Step Action 

1 Select one item, a group of items, or the top-level item, (if selecting the entire 
model) to export. 

2 Then either: 

• Use the menu and choose File->Export… or  

• Right mouse click menu and choose Export… 

3 A dialog appears displaying the name of the item selected for export.  The 
fully qualified name is displayed for assets and the point name is displayed 
for alarm groups.   

Select a path and filename as the target for export.  Depending upon the item 
selected, a default file name is supplied. 

4 When you select Export, the selected item and all associated children are 
exported intact to a single file. The export includes all information related to 
the exported items including: 

• Item name 

• Item Point name 

• Parent Item Point name 

• Property data 
 



Database Administration 
Export/Import 

48 Experion Enterprise Model Builder User's Guide  R301.1 
 Honeywell 11/06 

Import 
The Import function copies a file which contains assets or alarm groups and their 
associated children and adds it to the currently open asset model or alarm group.   

Considerations 

When ‘Import’ is selected, a lock occurs that prohibits any other users from making 
changes to the selected items.  The lock is released once the import is complete.  If any 
items are not available to be locked, an error is reported and the operation is canceled. 

To import a selected file into an EMDB: 
 

Step Action 

1 Use the menu and choose File->Import… 

2 A dialog appears showing a list of exported items based on a default 
directory.  You may navigate to a different directory, which changes the list of 
exported items.   
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Step Action 

 
 
• Select items for import from the list in the ‘Object’ window. Or, enter a 

specific Point Name for which to import.  Or, use the Directory for files to 
import, or use the Browse button to choose a different directory.   

• Enter a check in the ‘Use Selection List:’ field and then click on the 
dropdown window to select an item for import.   

• Enter a check in the ‘Overwrite Existing Objects’ field if you wish to 
overwrite any items containing the same name in the enterprise model with 
the imported items.  See Overwriting Existing Objects for more information.  

• Enter a check in the ‘Import CEE Assignments’ field if you wish to import 
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Step Action 
the CEE assignments with the items. 

  

 
ATTENTION 

Note that if an asset is exported and then imported back into the same model, 
check the ‘Overwrite Existing Objects’ box.   

 
3 Click ‘Import.’   

The import operation imports all items encountered in the exported file and 
moves the items to the parent specified in the file for each item. 

  
Note:  In the following paragraphs, “source” refers to the information in the exported file 
and “target” refers to the item in the EMDB. 

Overwrite Existing Objects 

Collisions may occur during a file import operation when the source contains a Point 
name that already exists in the EMDB.  In the Import dialog (step 2 above), you can 
specify whether names and items in the EMDB are to be overwritten with the names and 
item parameters of the source when a collision occurs.   

 If you choose not to Overwrite Existing Objects when collisions occur, (the default), the 
import continues.  Any errors encountered due to collisions during import are reported as 
shown in the following figure.  You can then modify the source selection and/or check 
the overwrite option and repeat the import.   

When you check the ‘Overwrite Existing Objects’ field in the Import dialog the 
following actions occur when a collision occurs: 

• If the parent of the source is different than the target parent, the item is moved to the 
parent specified in the source. 

• If the item name of the source is different than the target item name, the source item 
name is used. 

Missing Parents 

If the parent specified for the item to be imported does not exist in the EMDB and is not 
selected for import, the item will be added to the enterprise model as a top-level item.  A 
warning message is reported in the Importing Data dialog when the import operation is 
complete. 
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Duplicate Item Names 

The import operation ensures that an imported item name is unique for items of the same 
parent.  If there is an item already in the EMDB with the same name as an item to be 
imported, the imported item name is assigned a unique name.  The name is modified 
from the source name, and appended with a _n, where n is an integer, (For example an 
item named MIXING TANK in the database causes an imported item with the same 
name to be modified to MIXING TANK_1.) 
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Server Load Status and Error Messages 
Lock errors 

When you click on OK to begin a load operation, a lock occurs on the items selected for 
loading so that changes cannot be made to these items until the load is completed. These 
items may include the system configuration, asset model, alarm groups or server 
definitions.  If any of these items are already locked due to a user making changes to the 
items, then a message appears describing the item that is locked and the user’s name that 
is currently using it.  These locks should be cleared before proceeding with the load.  

Load errors 
When you begin a load operation, the system configuration portion of the enterprise 
model or the entire model is downloaded from the EMDB repository to selected servers 
on the system.  If errors occur during the load, an error message may appear, the load 
operation may abort or be cancelled, or the load may continue and complete.  The Load 
Status and Details / Errors columns in the Load dialog provide information on the status 
of the load and the cause of any errors.  The Load Status column of the dialog will 
indicate the action taken by the EMB. Depending upon the type of error or when during 
the load operation the error occurred, one of three conditions will result: 

1. The load operation aborts on the server where the error was detected, (see Load 
Abort errors).  Other servers selected for load may show a status of ‘Cancelled.’ 

2. The load continues and then fails because of a detected error, (see Load Failed 
errors).  

3. The load completes but reports that an error that was detected, (see Load Status).   

A description of the error appears in the Details/Errors column, or if there are multiple 
errors, a hyperlink, ‘[Double-click to view log file]’appears in the Details/Errors column. 
Double click on this link opens an error log in Notepad which describes the detected 
errors.   

Load Abort errors 

The system configuration or the entire enterprise model will be exported for loading onto 
the selected server(s).  If any errors are detected during export, the entire load operation 
is aborted and the error is reported to you. 

For example, if an error is detected during server validation, the load operation is aborted 
and the error is reported. The Load Status of “Abort” appears against the server(s) where 
the error was detected, as shown in the following figure. The Details/Errors column 
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describes the cause of the error. The Load Status of ‘Cancelled’ is shown for the other 
servers, meaning that the load operation did not run.  See Load Status and Error 
Messages for details on all Load Status states.   

 

 
 

Load Failed errors 

When an error is detected during a load operation, a Load Status of ‘Failed’ may appear 
against the server on which the load operation has failed. However, the load will continue 
for the other selected servers. A brief description of the error is reported to you in the 
Details/Errors column. 

For example, an error may occur when the system name or EMDB has changed and the 
Force Load option is not checked.  The error message will tell you to perform a load with 
the Force Load option checked (check box on Load dialog) if you wish to overwrite the 
current system configuration. 

If additional errors occur a log file is generated.  A hyperlink, ‘[Double-click to view log 
file],’ appears in the Details/Errors column against the server on which the errors have 
occurred.  Double click the link to view a log file generated by the errors. You should 
rectify the error and repeat the load for that particular server. 
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If any warnings are generated during the load operation, the load will complete, but the 
Load Status column will show “Complete (with warnings).”  This may happen when you 
have chosen the Force Load option, and the system name or EMDB has changed. The 
load proceeds but a log file will be generated.  Click on the link ‘[Double-click to view 
log file]’ to view a log file generated by the errors. You should rectify the error and 
repeat the load for that particular server. 

Server Load status 
The Load Status of a server can vary depending on whether any errors are detected 
during the load operation and the load status of other servers.  The ‘Load Status’ column 
indicates the state of the load operation for that server.   Any detected errors are briefly 
described in the ‘Details/Errors’ column, (see Error Messages for more details of these 
messages).  Valid load status for servers which may occur are described in the following 
table. 

 
Server Load Status Description and Result 

In Progress During the load operation the server is in the “In progress” 
state.  A description of the load/state is shown in the 
‘Details/Errors’ column.  

Complete If the load operation to the server completes without any 
warnings, the load status of the server changes to 
“Complete”. 

Complete (with warning) If the load operation on the server completes with an error, 
the load status of the server changes to “Complete (with 
warning)”. 

Click on the link ‘[Double-click to view log file]’ to view a 
log file generated by the errors. 

Abort Server(s) in the “Abort” state indicate that an error has 
occurred on these servers which prevent the load 
operation to proceed further. 

The load status of the server(s) where the error has 
occurred changes to “Abort”. The status of all other 
servers is blank, or Canceled. 

The ‘Details/Errors’ column contains a brief description of 
the error.  If the error generates a log file, click on the link 
‘[Double-click to view log file]’ to view the log file. 

Canceled Server(s) in the “Canceled” state indicate that the load 
operation will not proceed on these servers because one 
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Server Load Status Description and Result 
or more servers are in the “Abort” state. 

Since one or more servers are in “Abort” state and the 
load operation cannot proceed, load is canceled for all 
other servers. 

Failed Server(s) in the “Failed” state indicate that an error has 
occurred, and load operation cannot proceed on that 
server(s), but the load will continue for the other selected 
servers. 

The load status on the server(s) where the error has 
occurred changes to “Failed”.  

The Details column contains a brief description of the 
error. 

If the error generates a log file, click on the link ‘[Double-
click to view log file]’ to view a log file generated by the 
errors. 

 

Error messages 

If an error is detected during the load operation, a status of the load operation is indicated 
for that server in the ‘Load Status’ column.  The ‘Details/Errors’ column gives a brief 
description of the error. When multiple errors occur, a ‘[Double-click to view log file]’ 
link appears in the Details/Errors column.  Double click on the link to open the error log 
in Notepad which describes the errors.   

When errors are reported, look in the Enterprise Model Builder log file located at 
C:\Documents and Settings\All Users\Application 
Data\Honeywell\Experion\ServerName.log and then take steps to clear the 
error and then retry the load operation.   

For example, if you encounter the any of the following error messages during a load 
operation: 

Error in validating server names 
Error in validating point names 
Error in validating FQN 

Look in the log file and determine what items were causing validation to fail.  Look in 
the most recent file of the form ErrLog_n.txt, (n = a number).  Rename the items and 
then retry the load operation.     
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The error messages, which may be shown in the ‘Details/Errors’ column or in the error 
log, are listed in the following table. 

  
‘Details / Errors’ Message Description and Result 

Error in validating server names Indicates that validation of server names 
on the particular server has failed. The 
Load Status of the server is “Abort”. The 
load operation to that server is aborted.   

See Error messages for action to clear 
error.  

Error in validating point names Indicates that validation of point names 
on the particular server has failed. The 
Load Status of the server is “Abort”. The 
load operation to that server is aborted. 

See Error messages for action to clear 
error. 

Error in validating FQN Indicates that validation of Full Qualified 
Names (Full Item Names) on the 
particular server has failed. The Load 
Status of the server is “Abort”. The load 
operation to that server is aborted. 

See Error messages for action to clear 
error. 

Error in exporting system configuration Indicates that the export of system 
configuration has failed. The Load Status 
of all servers is “Abort”.  The load 
operation is aborted. 

Error in exporting Asset/Alarm group Indicates that the export of Asset model 
or Alarm groups has failed. The Load 
Status of all servers is “Abort”. The load 
operation is aborted. 

System Name changed – Repeat Load 
with Force Option set 

Indicates that the system name has been 
changed since the previous load. The 
Load Status of the server is “Failed.”  The 
load operation fails for that server. 

Click on the link ‘[Double-click to view log 
file]’ to view a log file generated by the 
errors. 
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‘Details / Errors’ Message Description and Result 

Repositroy changed – Repeat Load with 
Force Option set 

Indicates that the EMDB repository has 
been changed since the previous load. 
The Load Status of the server is “Failed.”  
Load fails for that particular server. 

Click on the link ‘[Double-click to view log 
file]’ to view a log file generated by the 
errors. 

Connection to server failed Indicates that there was error in 
connecting to the server. The Load 
Status of the server is “Failed.”  Load 
fails for that server. 

Error in loading system configuration Indicates that an unexpected error has 
occurred in loading system configuration. 
The Load Status of the server is “Failed.”  
The load operation fails for that server. 

Click on the link ‘[Double-click to view log 
file]’ to view a log file generated by the 
errors. 

Error in loading Asset/Alarm Group Indicates that an unexpected error has 
occurred in loading the asset model or 
alarm group. The Load Status of the 
server is “Failed.”  The load operation 
fails for that server. 

Click on the link ‘[Double-click to view log 
file]’ to view a log file generated by the 
errors. 

Unable to locate the network share 
SVRPTBLD. 

This error occurs when the network share 
‘SVRPTBLD’ is not found on the client.   

EMB may need to be reinstalled on the 
client.  
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Generate Reports 
You can generate reports that provide information on the items and the enterprise model 
structure.  The procedure is the same for generating reports for assets and alarm groups.   

To select a report type, print and or save a report: 
 

Step Action 

1 In the Enterprise Model Builder window use the menu and choose  

 File->Reports… 

The Reports dialog box appears. 

 An asset or alarm group containment report can be generated from this 
dialog.  The report will print the details of the selected item (asset or alarm 
group) and any items associated with it.    

2 You can make these selections in the Report dialog box: 

• Select the report type as Asset containment, or Alarm Groups 

• Click the Print button to initiate a printout of the report 

• Click the Preview button to review the selected report’s contents before 
printing it. 

• Click the Export button to intiate an export of the report to a disk file or 
Lotus Notes database in the file format of your choice. 

• Click the Close button to close the dialog box. 

• Click the Help button to call up this file. 
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Change operation permissions 
You can define permission security levels for certain operations in EMB, (such as, Set 
Preferences/Permissions and Rename Tags).  

Set Preferences/Permissions – This setting allows you to change the current preference 
settings for this application.  It allows you to set the user security level for making any 
changes to permissions.  Set this to ‘Manager’ security level to restrict any changes to the 
permissions by unauthorized users. 

Rename Tags – This sets the user security level for renaming the Tag name of an 
existing item.   Note that when you create an asset, or alarm group you enter a tag name 
in the properties form for that item.  The tag name can be changed during creation of the 
item without restrictions until the properties form is closed, adding the item to the model.  
Then, any change to the tag name is restricted to the user security level set in the 
permissions.   

Prerequisites 

• You have launched Configuration Studio and connected to a system with a logon 
security level of Engineer or greater.  

• You have an Enterprise Model Builder window open with either an asset model tree 
or alarm group tree displayed.  

To set or change the user level for permissions: 
 

Step Action 

1 Select Tools > Operation permissions… 

2 The PREFERENCES:PERMISSION Block dialog opens. 
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Step Action 

 
 

3 Click on the Permission Level and select the desired user level for the 
selected Operation.  The default settings are ‘At Least Engineer’ for the 
permissions. 

• Select Manager for the Set Preferences/Permissions. 

• Select the desired user level for the Rename Tags Operation. 

4 Click OK. 

Note that the settings will not take effect until the next time an EMB session is 
started.   
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Migration in Experion 

EMDB Migration 
The EMDB is migrated to a new release when the server node on which it resides is 
migrated to a new release.  Migration rules for the EMDB are consistent with existing 
Experion migration rules.  Once the EMDB server has been migrated to a new release, 
the EMB clients must also be upgraded to the same release.  Other servers in the system 
are not required to be migrated forward at the same time. It is possible for the EMDB 
server to connect to Experion servers operating at earlier releases, although the servers 
must be operating at Release 210 or later.  See the section ‘Interoperability’ in the 
‘Experion Migration User’s Guide’ for more information on this subject.   

The EMDB may reside on a system server which is part of the Experion system.  The 
EMDB may also exist on a standalone server, such as Experion Application Framework 
(EAF) server.  The migration of the EMDB is performed differently for these two 
servers.   

• The Experion server platform can be migrated as part of the normal Experion system 
migration procedures.  The Experion Migration application will migrate the EMDB, 
as well as other Experion engineering Tools and applications.  See the ‘Experion 
Migration User’s Guide’ for complete procedures to migrate Experion servers.   

• The standalone EMDB server must be migrated via a manual procedure.  The 
Experion Migration application does not support the migration of these nodes.  The 
basic tasks are as follows: 

a) Export each Enterprise Model (that is, server definitions, asset model, alarm 
groups and network tree that comprise the EMDB) on the existing release 

b) Install new release of EMB on the server 

c) Import each Enterprise Model into the EMDB of the server and load the EM to 
the servers. 

The procedure to migrate the EMDB on a standalone server is given below. 

Migration of areas and alarm groups in earlier Experion releases  
When migrating your system from an earlier Experion release (such as R101 or R201) to 
Experion Release 210 or later, the migration adapts the following items to work within 
the Enterprise Model: 

• Areas – Areas in existing Experion are converted to top-level assets in the asset 
model. 
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• Assets – Assets that were created from existing areas in previous Experion releases 
are added to the EMDB. 

• Alarm Groups – Existing alarm groups also are added to the EMDB. 

Migration of areas 
The conversion of areas in an existing Experion release to top-level assets in the asset 
model of an Enterprise model occurs as part of the Experion Server migration.  For 
example, an area referenced by SCADA and CB points is migrated to reference a new 
asset, (PARENTASSET).  Additionally, the SCADA and CB points are assigned a 
default item name, that is, the point name and the value of the SCANAREA parameter 
may be transferred to a new associated asset parameter. 

Migration of Assets and Alarm Groups from Servers to EMDB 

When you select the server task ‘Add a server to this system’ in Configuration Studio, 
you may also choose to migrate the existing assets and alarm groups on the server into 
the EMDB.  The asset model and alarm groups are exported from the server and 
imported into the EMDB; the server is added to the system model.   

You also have the option to skip the migration of the asset model and alarm groups for 
the ‘added’ server.  Note that there is no option to perform this migration at a later time, 
so you must confirm the request to continue or skip the migration. A load of the EM from 
the EMDB to the ‘added’ server will overwrite any existing model configurations on that 
server.  Therfore, if you choose to skip, any existing models in the server will be lost 
when a load to that server is performed. 

You also have the option to specify whether the operation should overwrite any entities 
(items) in case of a collision, (such as duplicate entities with the same names).  The 
Migration of Asset Model/Alarm Groups dialog is shown in Figure 5. 
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 Figure 5  Migration Dialog 

Migrate the EMDB on a standalone server    
The following procedure describes the migration of a standalone server that hosts the 
EMDB to a new release.  

Export each EM on the existing release: 
 

Step Action 

 
Note that if the server is redundant, migrate the backup server (Server B) 
first. 

1 Launch Configuration Studio and connect to the system with a logon security 
level of Engineer or greater. 

2 Select the Server Task  Export server definitions 

3 The Export dialog appears.  Select a destination for the export file.   

4 Click Export.  The system model will be copied to the destination directory.  
The file will be <system name>.cnf.xml 

5 If there are assets configured in this system, select the System Task 
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Step Action 
Configure Assets for this system 

6 Enterprise Model Builder starts.  Select the root name (top level asset) in the 
Asset model tree.  Right mouse click and choose Export… 

7 The Export dialog appears.  The root name must appear in the Point Name 
field of the dialog.   

• Select a destination for the export file.   

Note: Consider a destination on the same node as the system model. 

8 Click Export.  The asset model will be copied to the destination directory.  
The file will be <root name>.cnf.xml. 

9 If there are alarm groups configured in this system, select the System Task 
Configure Alarm Groups for this system 

10 Enterprise Model Builder starts.  Select the root name (top level alarm group) 
in the Alarm groups tree.  Right mouse click and choose Export… 

11 The Export dialog appears.  The root name must appear in the Point Name 
field of the dialog.   

• Select a destination for the export file.   

Note: Consider a destination on the same node as the system model. 

12 Click Export.  The alarm groups will be copied to the destination directory.  
The file will be <root name>.cnf.xml. 

13 In Configuration Studio fully expand the network tree and perform a screen 
capture to fully document the items in the tree structure.  

14 Export the network tree to an .xml file for reference.  Save the file under a 
directory name that identifies it as the Network model.   

15 Verify that all exported files exist at the destination locations.  Copy all 
exported files to external media for archiving.   

 

Install the new release of the EMDB: 
 

Step Action 

1 Obtain EMB Installer software media and install the new release of EMB on 
the standalone node. See EMB Installation for the procedure.   
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Import each EM and load to servers: 
 

Step Action 

1 Once EMB installation is complete, launch Configuration Studio and connect 
to the system with a logon security level of Engineer or greater.. 

2 Select the Server Task Import server definitions. 

3 The Import dialog appears.   

• Select the system model file exported from the previous release. 

• Select the appropriate directory for the destination of the file.   

4 Click Import.  Verify that the import is successful. 

5 Select the Server Task Load system configuration to servers. 

6 The Load dialog appears.  Select all servers and add a check to the Force 
Load check box.  

7 Click Load.  Verify that the load is successful. 

8 If there is an asset model that was exported in the previous release, then 
using Configuration Studio select the System Task Configure Assets for 
this system 

9 Enterprise Model Builder starts.  Choose File > Import… 

10 The Import dialog appears.   

• Select the asset model file exported from the previous release. 

• Select the appropriate directory for the destination of the file. 

11 Click Import.  Verify that the import is successful. 

12 Select Tools > Load Entire Model. 

13 The Load dialog appears.  Select all servers and add a check to the Force 
Load check box.  

14 Click Load.  Verify that the load is successful. 

15 If there is an alarm group model that was exported in the previous release, 
then using Configuration Studio select the System Task Configure Alarm 
Groups for this system 

16 Enterprise Model Builder starts.  Choose File > Import… 

17 The Import dialog appears.   
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Step Action 

• Select the alarm groups file exported from the previous release. 

• Select the appropriate directory for the destination of the file. 

18 Click Import.  Verify that the import is successful. 

19 Select Tools > Load Entire Model. 

20 The Load dialog appears.  Select all servers and add a check to the Force 
Load check box.  

21 Click Load.  Verify that the load is successful. 

 Migration is complete. 
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